Last Comment Bug 597932 - Dont remove RSS button from URL box
: Dont remove RSS button from URL box
Status: RESOLVED WONTFIX
[wontfix?]
:
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: Trunk
: All All
: -- minor with 75 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: :Gijs Kruitbosch
Mentors:
: 635185 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-19 20:54 PDT by Sergey
Modified: 2013-03-19 05:52 PDT (History)
36 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Mockup of possible combined bookmark / subscribe to feed user interface (95.65 KB, image/png)
2011-01-05 16:56 PST, Daniel O'Connor
no flags Details

Description Sergey 2010-09-19 20:54:03 PDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b5) Gecko/20100831 Firefox/4.0b5
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b5) Gecko/20100831 Firefox/4.0b5

Dont remove RSS button from URL box!!!
Its required to be in place, insted of bookmarks!

Reproducible: Always
Comment 1 Maniac Vlad Florin (:vladmaniac) 2010-09-20 06:02:30 PDT
Can see this on trunk builds. Feeds are working and Litmus tests can be passed, except for the missing of the "RSS icon"
Comment 2 jcspence74 2010-10-01 23:21:09 PDT
As the icon has been removed, is there any chance we can add the option in about:config to enable the icon/button in the url bar?  Would this feature need to be filed under a new bug?

Thanks!
Comment 3 jcspence74 2010-10-04 00:13:31 PDT
I have learned that devs don't like too many comments that aren't productive.. I am sorry for spamming the Bug 578967. I'll try to limit my comments from now on. I'm sure you all know that Bug 578967 is a done deal, but I and many other have been showing our support for the RSS icon in the Firefox 4 beta forum by voting.  We have moved to page 2 and are working to get to page 1.. If you would like to show your support for the icon you can vote here:

https://firefox.uservoice.com/forums/57440-firefox-4-beta/suggestions/1072765-do-not-remove-rss-feed-icon
Comment 4 Sergyk 2010-10-04 00:40:05 PDT
add option to about:config like show rss icon, plz. Without its icon i don't see have site rss or no. Its not right. many  users are against about removing rss icon.
Thanks.
Comment 5 jcspence74 2010-11-12 09:36:00 PST
Some statistic..

The request "Do NOT remove RSS feed Icon" is now on the first page of the Firefox 4 Beta Forum.. https://firefox.uservoice.com/forums/57440-firefox-4-beta

Firefox Input Dashboard - "RSS".. http://input.mozilla.com/en-US/search/?product=firefox&q=rss
Comment 6 Kroc Camen 2010-11-14 09:38:55 PST
I just came across a squarespace blog that I couldn’t subscribe to because there was no RSS icon on the page, and none in the chrome!

Don’t remove the ruddy RSS icon. When I design sites, I rely upon the chrome doing the right thing for the browser / OS when it comes to RSS and I don’t want RSS icons cluttering up my page design, pointing to XML files users don’t know what to do with.
Comment 7 Sascha Grage 2010-11-14 09:48:24 PST
> I just came across a squarespace blog that I couldn’t subscribe to because
> there was no RSS icon on the page, and none in the chrome!

RSS Icon:
https://addons.mozilla.org/de/firefox/addon/241029/
Comment 8 Kroc Camen 2010-11-14 10:49:22 PST
@Sasche Garge Get a clue. It is the browser’s job to do the best in making RSS useful and meaningful to users. If they remove the icon by default, they may as well remove the whole damn functionality.

Hey Mozilla, maybe the reason people don’t use RSS enough is because your RSS reader completely sucks and hasn’t been looked at for years!
Comment 9 jcspence74 2010-11-22 19:19:30 PST
The request "Do NOT remove RSS feed Icon" over at uservoice.com, was just declined, which hides it from the forum.. there is a new one called "Allow users to place the RSS button in the address bar in the same way as Reload/Stop & Bookmarks".. please vote for this new request.

https://firefox.uservoice.com/forums/57440-firefox-4-beta/suggestions/1243193-allow-users-to-place-the-rss-button-in-the-address
Comment 10 Mahesh Asolkar 2010-11-23 10:14:47 PST
One way to work around this is to customize the Navigation Toolbar (View -> Toolbars -> Customize) and pull in the RSS button on the toolbar.

From my experience, this works fine in Windows (Windows 7 anyway), since the button looks "enabled" when a page has RSS feeds and "Disabled" when a page does not.

In Linux, however, the toolbar button always looks the same. You cannot tell if a page has a feed until you hover the mouse over the button.

I can't say what happens on a Mac.

May be the button can be fixed so that it is a bit more usable.
Comment 11 Kroc Camen 2010-11-23 12:04:37 PST
This is more than one bug.

RSS discoverability and presentation is important. RSS is there to help users so they don’t have to open 100 sites each day. If Mozilla want to make the web easier for users, they should be promoting RSS.

If you remove the RSS button from the UI by default then the functionality basically doesn’t exist. Regular users would never add the RSS button if they didn’t even know what RSS is.

The RSS button was used so little (3%) because it is simply not evident at all what it does if you don’t know what the RSS icon means. Regular users do not click buttons they don’t understand unless it’s "OK" or "Cancel".

Removing it from the UI does not solve the problem that RSS is not used enough.

The RSS icon and the term "RSS" has no meaning and does not explain what RSS is to new users. This needs to be rectified rather than removing the functionality from the user’s reach. (and forcing web developers to clutter their pages with RSS buttons because Firefox no longer includes one by default -- and that doesn’t help users either)

Mozilla, either keep the RSS button by default, or rethink your feed discoverability and presentation completely. Removing the button only hurts users and developers.
Comment 12 Henrik Skupin (:whimboo) 2010-12-13 23:05:16 PST
Alex, I assume we can close this bug as wontfix?
Comment 13 Alex Faaborg [:faaborg] (Firefox UX) 2010-12-14 15:13:54 PST
See discussion in bug 578967
Comment 14 Markus Popp 2010-12-14 15:32:29 PST
How many percent users do have to disagree with a decision that you decide to revert it?

I guess 100 % is not enough:

http://input.mozilla.com/en-US/search/?product=firefox&q=rss+icon

^^^ it's data that Mozilla asked for

(yes, I know a bug report is not the right place for this discussion; but if users don't get heard on the places which are created for that purpose, like Mozilla Input, I have to give it a try here; sorry)
Comment 15 HyperHacker 2011-01-02 13:03:40 PST
So if you drop the RSS button, less people are going to realize the functionality exists... as a result, less people will use RSS... webmasters will see this low usage and start to decide RSS isn't worth providing anymore... everyone who does use RSS (even outside of Firefox) suffers from less and less sites offering it. Thanks, guys.
Comment 16 Benjamin Melançon 2011-01-02 14:58:41 PST
Can the status be reconsidered?  This is an unfortunate regression.
Comment 17 Michael Pereira 2011-01-02 15:11:08 PST
Don't kill RSS please : http://camendesign.com/blog/rss_is_dying
Comment 18 Jacques Pyrat 2011-01-03 05:39:46 PST
I too rely on this icon to design web site. Don't remove it !
Comment 19 Giovanni Pelosi 2011-01-03 07:12:15 PST
RSS icons was very useful for a Google Reader/Feedly addicted like me.

Reinterpret RSS in twitter era can be an add-on task (there are many different tastes here), but a "robust" default handling of "push"-ed contents is a must ...
Comment 20 Marcin Kasperski 2011-01-04 10:24:51 PST
Please, don't remove RSS icon from url box. At least give me an option to keep it. 

This icon is enormously useful as indicator whether given page has RSS feed and as easily accessible subscription button.
Comment 21 Michal S. 2011-01-04 16:19:00 PST
Please don't remove RSS icon from URL box.
Comment 22 ekeyme 2011-01-05 00:37:52 PST
Don't remove RSS icon, please. This icon can help me notice easily sites I viewing that support a rss. It's a very VISIBLE ICON than the Subscription Icon which maybe irregular placed on the web page. So I think if devs really try to remove it that is more than a BUG. Does this cute icon hold in address bar really gets in our way to do other things???
Comment 23 Adam 2011-01-05 04:19:38 PST
A nonsense decision, and arrogant with it. Another push towards Chrome for me.
Comment 24 Daniel O'Connor 2011-01-05 16:55:46 PST
Are there alternative discovery patterns which might be acceptable the users who previously utilized the RSS icon; given it's not coming back?

I note that:
 * The right click context menu contains "bookmark this page" functionality. For advanced users who do not utilize bookmarks; but do utilize RSS readers as a replacement, would it be appropriate the enhance that option?
7% used the icon, is any one able to say what % use the right click bookmark option?
 * The previously mentioned combined star -> bookmark UI + subscribe approach could be a suitable replacement to allow advanced users to maintain current behaviour without overwhelming novice users.
Comment 25 Daniel O'Connor 2011-01-05 16:56:44 PST
Created attachment 501521 [details]
Mockup of possible combined bookmark / subscribe to feed user interface
Comment 26 Mahesh Asolkar 2011-01-05 17:05:47 PST
(In reply to comment #24)
> Are there alternative discovery patterns which might be acceptable the users
> who previously utilized the RSS icon; given it's not coming back?

As mentioned in comment #10, one can pull in the RSS button into the toolbar. It provides both discovery and access to feeds. At the time that comment was made, Linux version of Minefield had problems with the state of RSS button. But I see that it has been fixed since.

To me it is a reasonable replacement, although not quite the same.
Comment 27 Simon Charette 2011-01-05 17:28:37 PST
I must admit the new pullable version works quite well as a replacement for the location bar now that it's fixed on Linux.

You must however admit that this feature is kind of hidden and that users used to have the rss icon appear in the location will have no clue if the feature stopped working or if the page stopped providing RSS. How are they supposed to know they must pull a new button in order to get the feature back somehow? By Googling it and reaching this page?

I think this decision is harmful for both RSS and Firefox.
Comment 28 Simon Charette 2011-01-06 21:34:58 PST
I really like how the latest FF3 releases moved the reload and stop buttons to the right of the "awesome" bar. I guess it is to make sure users don't get confused when the buttons are merged into the bar with FF4.

I think figuring out a way to achieve the same thing with the RSS button is a must.

Is there metrics FF can use when upgrading to v4 in order to automatically add the button if it has been used in the past?
Comment 29 Cork 2011-02-18 02:42:03 PST
*** Bug 635185 has been marked as a duplicate of this bug. ***
Comment 30 Artem Skoretskiy 2011-03-31 02:33:37 PDT
RSS icon in location bar immediately gives you the answer - is there any RSS feeds for this page or not. It is shown to each user of the browser and there's no chance user may miss the RSS of the page. Let's say it is auto-discover of information - site RSS feeds.

Having in mind that feeds gives ability to manage the information stream - it makes it really important and handy.

Removing RSS icon simply kills auto-discovering RSS feeds - you wouldn't ever see page feeds if you didn't intend subscribing to it. Both RSS button and feeds submenu in bookmarks don't satisfy these needs.

If developers f**k your opinion - simply use https://addons.mozilla.org/ru/firefox/addon/rss-icon/

And yes, it looks really fine RSS icon and bookmark icon together in location bar. Google Chrome is not a good idol to follow.

Note You need to log in before you can comment on or make changes to this bug.