'Created by' in extension's About dialog changes from creator in install.rdf to information from amo

RESOLVED DUPLICATE of bug 603409

Status

()

RESOLVED DUPLICATE of bug 603409
8 years ago
8 years ago

People

(Reporter: john.p.baker, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

8 years ago
Created attachment 476745 [details]
about popup

My extension contains the following in the install.rdf:

  <em:name>HashColouredTabs+</em:name>
  <em:creator>Terry Yuen</em:creator>
  <em:developer>John P Baker</em:developer>
  ...

Initially, the information shows properly in Tools/Add-ons and on the About pop-up but, at some subsequent stage, the By gets replaced by 'John P Baker' - presumably from the amo site.

Mozilla/5.0 (Windows NT 5.0; rv:2.0b7pre) Gecko/20100919 Firefox/4.0b7pre
(Reporter)

Comment 1

8 years ago
Created attachment 476787 [details]
wrong information
(Reporter)

Comment 2

8 years ago
Created attachment 476789 [details]
after deleting addons.sqlite and restarting
This is for the moment intentional. Why do you have a different author listed on AMO to that in the install.rdf?
(Reporter)

Comment 4

8 years ago
I can see the arguments for this in listing and details so I will morph this bug back to my initial concern - the About dialog. I feel this should show the correct (and possibly legal) information from the install.rdf and not something guessed at from amo.

In my case I took an extension created by someone else and adapted it for Fx 2.0; In the more visible case of DOM inspector many people worked on it and Shawn is the current custodian.
Summary: Extension listing changes from creator in install.rdf to 'by' from amo → 'Created by' in extension's About dialog changes from creator in install.rdf to information from amo
(Reporter)

Updated

8 years ago
Attachment #476789 - Attachment is obsolete: true
(Reporter)

Updated

8 years ago
Attachment #476787 - Attachment is obsolete: true
(Reporter)

Comment 5

8 years ago
Two names on amo are also odd; For TabCloser the about dialog promotes johnath to Creator and demotes Gavin to Developer, after the change to amo data.
There are a couple of things going on here. Firstly we wanted a way to link to details about the author, the AMO data provides us with that however in order to do it we have to use the AMO author data (or attempt to marry author names on AMO with those in the install.rdf which I don't care to attempt). Unfortunately AMO data only includes multiple authors, it does not separate out the concepts of creators and developers like install.rdf does.
(Reporter)

Comment 7

8 years ago
AFAICT my concerns are covered by bug 603409.

Globally setting extensions.getAddons.cache.enabled to false has the desired effect, so I am assuming that doing so particularly for one extension will do likewise.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603409
You need to log in before you can comment on or make changes to this bug.