Back button does not scroll to anchors in scrollable DIVs

RESOLVED DUPLICATE of bug 565008

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 565008
8 years ago
4 months ago

People

(Reporter: kybernetikos@gmail.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

When anchors are inside scrollable divs, specifying the #anchor name will correctly cause the div to scroll to the appropriate anchor.  However, if you press the back button, the url in the location bar will  update, but the scrollable div will not be scrolled.

Reproducible: Always

Steps to Reproduce:
1. Browse to the attached file.
2. Click the 'fred' link, notice that the div scrolls to show 'fred'.
3. Click the 'jim' link, notice that the div scrolls to show 'jim'.
4. Press the back button on the browser.
Actual Results:  
The url updates to show #fred, but the div is still scrolled to show 'jim'.

Expected Results:  
The div should have scrolled to show 'fred'.
(Reporter)

Comment 1

8 years ago
Created attachment 476770 [details]
Test case that shows incorrect back button behaviour
(Reporter)

Comment 2

8 years ago
I'd like to add that if you enter the appropriate # manually, and hit enter, the div will scroll, so you can click back, then click in the location bar and hit enter.

Updated

8 years ago
Component: Bookmarks & History → Document Navigation
Product: Firefox → Core
QA Contact: bookmarks → docshell
This is a known issue....  Restoring from history restores the viewport scroll positions but not any others, and we don't do anchor scrolls on restoring from history to avoid stomping on non-default scroll positions (the common case)....
Whiteboard: DUPEME

Comment 4

8 years ago
Scroll feature does not work in scrollable areas on all pages on all sites . . . new development. This feature worked previously
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565008

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.