Tags of bookmarks is lost doing UNDO after a CUT or DELETE

RESOLVED FIXED in Firefox 4.0b10

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Antonio Maia, Assigned: mak)

Tracking

({dataloss, regression})

Trunk
Firefox 4.0b10
x86
Windows XP
dataloss, regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(status1.9.2 ?)

Details

(Whiteboard: [fixed-in-places])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 GTB7.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 GTB7.1

After a "cut" (Ctrl+X) of bookmark entry followed by an "undo" (Ctrl+Z), its tag disappears.

Reproducible: Always

Steps to Reproduce:
1. Mark a bookmark with a tag
2. Ctrl+X (cut)
3. Ctrl+Z (undo)
4. You the bookmark back, but without the original tag
Actual Results:  
I got the bookmark back, but without the original tag

Expected Results:  
The natural result would be to get the same entry, with the original tag
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch
(Assignee)

Comment 1

7 years ago
confirmed, it's pretty weird.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss
(Assignee)

Updated

6 years ago
Blocks: 560198
(Assignee)

Comment 2

6 years ago
Created attachment 503574 [details] [diff] [review]
patch v1.0

Looks like we lose tags also for the simple "delete a bookmark and undo" case and it's a FX4 regression.
The patch was not that hard or time consuming.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #503574 - Flags: review?(dietrich)
(Assignee)

Updated

6 years ago
Keywords: regression
Summary: Tags of bookmarks disappear after "cut" (CTRL+X) + "undo" (Ctrl+Z) → Tags of bookmarks is lost doing UNDO after a CUT or DELETE
(Assignee)

Updated

6 years ago
Flags: in-testsuite?
Attachment #503574 - Flags: review?(dietrich)
Attachment #503574 - Flags: review+
Attachment #503574 - Flags: approval2.0+
(Assignee)

Comment 3

6 years ago
http://hg.mozilla.org/projects/places/rev/c3bec086d8f8
Flags: in-testsuite? → in-testsuite+
Whiteboard: [fixed-in-places]
http://hg.mozilla.org/mozilla-central/rev/c3bec086d8f8
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
Blocks: 467530
Blocks: 627416
No longer blocks: 467530
status1.9.2: --- → ?
Version: 3.6 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.