If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Support custom servers with self-signed certificates

RESOLVED DUPLICATE of bug 591520

Status

Cloud Services
Firefox Home
RESOLVED DUPLICATE of bug 591520
7 years ago
7 years ago

People

(Reporter: st3fan, Assigned: st3fan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

7 years ago
FxHome does not support self-signed certificates for custom servers. This is a common scenario for people running their own server.

Supporting self-signed certificates will require some refactoring of the network code. Currently synchronous calls are made in a separate thread. Those synchronous calls have no way to support ssl exceptions. Only the async calls (NSURLConnection + delegate) can do that.
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591520
(Assignee)

Updated

7 years ago
Summary: Support self-signed certificates → Support custom servers with self-signed certificates
You need to log in before you can comment on or make changes to this bug.