Sync UI: "(null)" appears as username on Android

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

Trunk
All
Android

Details

(Reporter)

Description

8 years ago
Steps to reproduce:
1. Start a recent Fennec Android nightly with a fresh profile.
2. Enter your Sync credentials and press "Connect"
3. Wait for Sync to connect successfully.

Expected results: Device name looks like "mbrubeck's Fennec on Nexus One"

Actual results: Device name looks like "(null)'s Fennec on Nexus One"
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
(Reporter)

Comment 1

8 years ago
Fixed by bug 598010.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
I find that highly unlikely since that was pushed on Sep 23 14:17:16 2010 -0700 [1] and my build is from 9549708d2e90, which was pushed on Sep 24 01:54:40 2010 -0700 [2].  (about:buildconfig doesn't say which version of mobile-browser I've been built off of, which is a bit frustrating).

This may be a regression from that, however.

[1] http://hg.mozilla.org/mobile-browser/pushloghtml?changeset=2b0205277b24
[2] http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=9549708d2e90
Blocks: 598010
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 3

8 years ago
The latest Android nightly was built from:
http://hg.mozilla.org/mozilla-central/rev/9549708d2e90
http://hg.mozilla.org/mobile-browser/rev/e382aca88005

so it does indeed have the patch from bug 598010.  So if you are seeing this bug in today's nightly build, then it is not fixed.  :(

Just to be clear: The default device name is set once, when you first connect to a sync account.  Did you connect to a sync account in a fresh profile, using today's build?
Er, whoops.  I thought this was a different bug that you had closed.  My bad!
No longer blocks: 598010
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Depends on: 598010
Resolution: --- → FIXED
Verified fixed on : 

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b7pre)Gecko/20100924 Firefox/4.0b7pre Fennec/2.0b1pre

Mozilla/5.0 (Android; Linux armv71; rv2.0b7pre) Gecko/20100924 Firefox/4.0b7pre Fennec/2.0b1pre
Status: RESOLVED → VERIFIED
clearing out blocking nom since the bug is fixed.
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.