M18 crash when ctrl-<arrow key> is pressed

VERIFIED DUPLICATE of bug 54694

Status

()

Core
Keyboard: Navigation
P3
critical
VERIFIED DUPLICATE of bug 54694
17 years ago
16 years ago

People

(Reporter: Dan Price, Assigned: Chris McAfee)

Tracking

({crash})

Trunk
Sun
Solaris
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Pressing ctrl-up-arrow, ctrl-right-arrow, etc. reproducibly crashes the
browser on Solaris every time I try it.  This is under m18.

Here is the stack trace:

 fda2e0d8 nsConvertCharCodeToUnicode__FP12_GdkEventKey (1e8718, fda37ff8,
fd79311c, 0, ffbee904, fd5f9384) + fc
 fda2e2e8 InitKeyPressEvent__FP12_GdkEventKeyPvR10nsKeyEvent (1e8718, 243308,
ffbee8a8, 85, 81010100, ff0000) + 50
 fda2e954 handle_key_press_event__FP10_GtkObjectP12_GdkEventKeyPv (0, 1e8718,
243308, 3400, ffbee904, ffbee900) + 144
 fda2ee78 ???????? (1e8718, 6e11e8, 0, 0, b04d0, b0a18)
 fda2ecec handle_gdk_event__FP9_GdkEventPv (1e8718, 0, fd7f6f58, fda2eb18,
b04d0, 0) + 1d4
 fd7c9eb8 gdk_event_dispatch (1e8718, ffbeeb58, 0, 0, 0, ffbeeab0) + 98
 fd785e88 g_main_dispatch (470, 470, 4d4, aa0, 4d4, aa0) + 128
 fd786724 g_main_iterate (fd7ab944, fd7ab8b0, 4d4, aa0, 4d4, aa0) + 7bc
 fd786938 g_main_run (2057e8, fd7f7060, c5c08, 0, 0, 0) + b8
 fd8bfcf0 gtk_main (2c00, fda25f54, a0e18, fd6bc304, 0, 0) + 10c
 fda26184 Run__10nsAppShell (baae8, fda2614c, baae8, 1c9888, 0, ffe) + 38
 fe01de7c Run__17nsAppShellService (b6e70, fe01de68, b6e70, fe01d1c4, 3f8, 1) + 14
 00016f9c ???????? (0, ff2cf650, 0, 5, 100d4, 0)
 00017488 main     (1, ffbeef64, ffbeef6c, 36e58, 0, 0) + 12c
 00014104 _start   (0, 0, 0, 0, 0, 0) + 5c
dp, are you able to reproduce this with a more recent build [either trunk or
branch]?

i don't have access to solaris --fwiw, i cannot repro this using mozilla trunk
bits from 2000.11.08.08 on linux.

mcafee, d'you see this?
Assignee: don → mcafee
Keywords: crash

Comment 2

17 years ago
Duplicate of bug 59192 marking as such.

*** This bug has been marked as a duplicate of 59192 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Keyser, I think you made a typo.  Bug 59192 deals with scrolling down when you
press the spacebar in a form.  Following a chain of duplicates, do you mean
bug 54694?  Reopening so that it can be re-resolved as a duplicate.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

17 years ago
yeah thats what i meant sorry about that.

*** This bug has been marked as a duplicate of 54694 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.