If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

problems with <nobr></nobr>

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
P3
normal
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Gereon Ruetten, Assigned: harishd)

Tracking

({compat})

Trunk
Future
x86
All
compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test11 i686; en-US; m18) Gecko/20001110
BuildID:    Mozilla/5.0 (X11; U; Linux 2.4.0-test11 i686; en-US; m18) Gecko/20001110

as you can see on the sample URL, Mozilla breaks the lines, but in evrey line i
inserted a <nobr>content</nobr>
Other browser show it correctly !

Reproducible: Always
Steps to Reproduce:
1.no special needs to reproduce


Expected Results:  no line has to be break

Comment 1

17 years ago
-->layout...this happens on win32 trunk too, and only on each 2nd line
Assignee: asa → clayton
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
OS: Linux → All
QA Contact: doronr → petersen
Summary: problems with <nobr></nobr> → problems with <nobr></nobr>
Assignee: clayton → jst
Please triage.
The content model that the parser builds from this page is nowhere close to what
the page contains, the page contains things like this:

<nobr><font ...>some text</font></nobr><br>

and the parser sees most of those (it gets the first line right, or close at
least) lines as:

  <nobr/>
  <font ...>
     some text
  </font>
  <br/>

reassignig to harishd.
Assignee: jst → harishd

Updated

17 years ago
QA Contact: petersen → lorca
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
(Assignee)

Comment 5

17 years ago
I'm not able to reach the above URL. 
Whiteboard: UNABLE TO REACH THE ABOVE URL
(Reporter)

Comment 6

17 years ago
Because i moved to a other town, the url has changed
(Assignee)

Comment 7

17 years ago
Gereon: Thanx for updating the URL.
Whiteboard: UNABLE TO REACH THE ABOVE URL
(Assignee)

Comment 8

17 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 
Target Milestone: mozilla0.9.1 → Future
Component: Layout → Parser
Keywords: compat

Comment 9

16 years ago
WFM on Mozilla 1.0 RC1 (2002041711), Windows NT 4.0

Comment 10

14 years ago
unreachable testcase, last comment was worksforme, resolving. please reopen if
this is still a problem for you and you can provide a testcase. thanks.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.