Keep bar-style notifications for Firefox 4 on Linux instead of doorhanger notifications which breaks consistency on GNOME desktop

VERIFIED WONTFIX

Status

()

Firefox
General
VERIFIED WONTFIX
7 years ago
7 years ago

People

(Reporter: antistress, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [doorhanger], URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

I'm running Firefox on GNOME

New Remember Password doorhanger notification (Firefox 4) breaks consistency
over the GNOME desktop which uses GTKInfoBar (GTKInfoBar looks like current Firefox 3.6 bar-style notifications system) : very bad from my point of view and
regarding user experience.

Until know Firefox made effort to integrate well in each desktop and that is
good if not necessary. Breaking consistency by changing the notification system would be an important regression to me.

I think that, on GNOME, Firefox should keep the current Firefox 3.6 bar-style
notifications system.

Thanks

Reproducible: Always




My intial comment was posted under Bug 567814 "Convert Remember Password notification bar to a doorhanger notification" (see c#45)
It also applies to Bug 588309 "Convert change password to a doorhanger
panel" for the same reason.
I had a brief discussion under Bug 572482 "[Linux] UI Refresh" which seems to be a meta-bug for Linux UI (see c#48 to 52)
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
I've opened a discussion thread on mozilla usenet groups :
http://groups.google.com/group/mozilla.dev.usability/browse_thread/thread/21871b42093e5196#

Please, discuss it there as Bugzilla is not really made and easy to use for discussion...
(Reporter)

Comment 2

7 years ago
Thanks Nicolas Mandil : Reading Alex Faaborg explanations, i surrender.
As far as i'm concerned this bug can be set as WONTFIX

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Whiteboard: [doorhanger]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.