Last Comment Bug 598339 - "GPU Accelerated Windows 0/1" needs to be simplified to prevent user confusion
: "GPU Accelerated Windows 0/1" needs to be simplified to prevent user confusion
Status: RESOLVED FIXED
[mentor=joe@drew.ca]
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla11
Assigned To: Atul Aggarwal
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 590841
Blocks: about:support++
  Show dependency treegraph
 
Reported: 2010-09-21 08:15 PDT by Dave Garrett
Modified: 2011-11-30 03:50 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.11 KB, patch)
2011-11-27 12:17 PST, Atul Aggarwal
joe: review+
Details | Diff | Splinter Review

Description User image Dave Garrett 2010-09-21 08:15:22 PDT
A user asked in another bug what "GPU Accelerated Windows 0/1" means? It means nothing is accelerated: zero out of a possible one windows. That's nice and cryptic for the about:support page.

Please make this case simpler. When there is no acceleration enabled, simply say "No GPU Acceleration" or just "none" in place of "0/1" or any "0/n".
Comment 1 User image Dave Garrett 2010-09-21 08:30:16 PDT
Even just a plain "0" would be preferable, actually.
Comment 2 User image Joe Drew (not getting mail) 2010-09-21 09:08:19 PDT
Have users been confused by (for example) 2/2 Direct3D 9?
Comment 3 User image Dave Garrett 2010-09-21 09:17:27 PDT
I don't know. I would guess it's possible. If you want to reformat entirely, I'd suggest something along the lines of:

GPU Accelerated Windows:
    x accelerated windows (y total windows open) using _____ for acceleration
Comment 4 User image Dave Garrett 2010-09-21 09:55:20 PDT
I'm putting "[strings]" on the whiteboard, but if you're stringphobic right now just comment 1 would suffice as a bare minimum for my initial case.

If we could get the full clarification of comment 3 + comment 0 ("none" or "No GPU Acceleration" when applicable) that would be the best solution.
Comment 5 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2010-09-24 14:37:08 PDT
It's not particularly important that users understand everything on about:support, given its purpose. I don't think we should spend time trying to fix this now.
Comment 6 User image Dave Garrett 2010-09-24 14:55:37 PDT
Then I'll take the lazy fix if you don't think it's worth bothering with the more explanatory one.

http://hg.mozilla.org/mozilla-central/file/76b7f615bab9/toolkit/content/aboutSupport.js#l219

219   let msg = acceleratedWindows + "/" + totalWindows;
220   if (acceleratedWindows)
221     msg += " " + mgrType;

Just move the "/n" part down a bit to be:

219   let msg = acceleratedWindows;
220   if (acceleratedWindows)
221     msg += "/" + totalWindows + " " + mgrType;

I'd submit an actual patch, but I don't have an hg checkout or build environment for Firefox.
Comment 7 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2010-09-28 23:31:50 PDT
Sure, I'd be fine with that.
Comment 8 User image Joe Drew (not getting mail) 2011-11-25 09:46:31 PST
I believe comment 6 should be enough for someone to implement this, but should that not be the case, please ask me questions!
Comment 9 User image Atul Aggarwal 2011-11-27 12:17:25 PST
Created attachment 577154 [details] [diff] [review]
Patch v1

What's current consensuses regarding this bug? Complete rewrite or just simply displaying "0". In case of later, attaching the patch.
Comment 10 User image Joe Drew (not getting mail) 2011-11-28 12:55:28 PST
Comment on attachment 577154 [details] [diff] [review]
Patch v1

Review of attachment 577154 [details] [diff] [review]:
-----------------------------------------------------------------

I'm fine with this. I don't have any real feeling on whether it fulfills the intent of this bug, though!
Comment 11 User image Atul Aggarwal 2011-11-28 19:13:59 PST
I definitely think it will prevent confusion among users. I also got confused first time when I looked at 0/1 (It looks like either 0 or 1 or something in those lines). It can be '0 of 1' also.
Comment 13 User image Marco Bonardo [::mak] 2011-11-30 03:50:56 PST
https://hg.mozilla.org/mozilla-central/rev/a99b6b77bcc4

Note You need to log in before you can comment on or make changes to this bug.