Closed Bug 598339 Opened 9 years ago Closed 8 years ago

"GPU Accelerated Windows 0/1" needs to be simplified to prevent user confusion

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla11

People

(Reporter: davemgarrett, Assigned: atulagrwl)

References

(Blocks 1 open bug)

Details

(Whiteboard: [mentor=joe@drew.ca])

Attachments

(1 file)

A user asked in another bug what "GPU Accelerated Windows 0/1" means? It means nothing is accelerated: zero out of a possible one windows. That's nice and cryptic for the about:support page.

Please make this case simpler. When there is no acceleration enabled, simply say "No GPU Acceleration" or just "none" in place of "0/1" or any "0/n".
Even just a plain "0" would be preferable, actually.
Have users been confused by (for example) 2/2 Direct3D 9?
I don't know. I would guess it's possible. If you want to reformat entirely, I'd suggest something along the lines of:

GPU Accelerated Windows:
    x accelerated windows (y total windows open) using _____ for acceleration
I'm putting "[strings]" on the whiteboard, but if you're stringphobic right now just comment 1 would suffice as a bare minimum for my initial case.

If we could get the full clarification of comment 3 + comment 0 ("none" or "No GPU Acceleration" when applicable) that would be the best solution.
Whiteboard: [strings]
It's not particularly important that users understand everything on about:support, given its purpose. I don't think we should spend time trying to fix this now.
Whiteboard: [strings]
Then I'll take the lazy fix if you don't think it's worth bothering with the more explanatory one.

http://hg.mozilla.org/mozilla-central/file/76b7f615bab9/toolkit/content/aboutSupport.js#l219

219   let msg = acceleratedWindows + "/" + totalWindows;
220   if (acceleratedWindows)
221     msg += " " + mgrType;

Just move the "/n" part down a bit to be:

219   let msg = acceleratedWindows;
220   if (acceleratedWindows)
221     msg += "/" + totalWindows + " " + mgrType;

I'd submit an actual patch, but I don't have an hg checkout or build environment for Firefox.
Sure, I'd be fine with that.
I believe comment 6 should be enough for someone to implement this, but should that not be the case, please ask me questions!
Whiteboard: [mentor=joe@drew.ca]
Attached patch Patch v1Splinter Review
What's current consensuses regarding this bug? Complete rewrite or just simply displaying "0". In case of later, attaching the patch.
Assignee: nobody → atulagrwl
Attachment #577154 - Flags: review?(joe)
Comment on attachment 577154 [details] [diff] [review]
Patch v1

Review of attachment 577154 [details] [diff] [review]:
-----------------------------------------------------------------

I'm fine with this. I don't have any real feeling on whether it fulfills the intent of this bug, though!
Attachment #577154 - Flags: review?(joe) → review+
I definitely think it will prevent confusion among users. I also got confused first time when I looked at 0/1 (It looks like either 0 or 1 or something in those lines). It can be '0 of 1' also.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/a99b6b77bcc4
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.