Ability to filter the pushlog by rev id

RESOLVED FIXED

Status

Tree Management Graveyard
TBPL
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: mounir, Assigned: mounir)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 477404 [details] [diff] [review]
Patch v1

It would be nice to be able to filter the pushlog to show only a push containing a specific revision.

The attached patch let the user specify "rev=" in the URL to filter the pushlog to a specific revision.
Attachment #477404 - Flags: review?(arpad.borsos)
Comment on attachment 477404 [details] [diff] [review]
Patch v1

>+++ b/js/PushlogJSONParser.js
>+          // Look at the 12 first nodes characters when filtering by revision.
>+          if (rev && patch.node.substring(0, 12) == rev) {
>+            revFound = true;
>+          }>           patches.unshift({rev: patch.node.substr(0,12), author: author,
>                   desc: Controller.stripTags(patch.desc), tags: tags});

Just for consistency, we should use the same function in both places (substr vs substring, I don’t care which one). You can also make it a var in the function so we avoid that redundancy alltogether.
Attachment #477404 - Flags: review?(arpad.borsos) → review-
(Assignee)

Comment 2

8 years ago
Created attachment 477422 [details] [diff] [review]
Patch v1.1
Attachment #477404 - Attachment is obsolete: true
Attachment #477422 - Flags: review?(arpad.borsos)
Attachment #477422 - Flags: review?(arpad.borsos) → review+
(Assignee)

Comment 3

8 years ago
http://hg.mozilla.org/users/mstange_themasta.com/tinderboxpushlog/rev/4450f4f7e9c1
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Deployed. Thanks Mounir!
Duplicate of this bug: 576544
Blocks: 576544
This doesn't actually seem to work -- e.g.

http://tests.themasta.com/tinderboxpushlog/?tree=MozillaTry&rev=15e65c1f91da doesn't show any results, even though the push certainly happened.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

8 years ago
This has been broken by another commit and should be fixed by this one according to Arpad:
http://hg.mozilla.org/users/mstange_themasta.com/tinderboxpushlog/rev/58f485db128d
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(In reply to comment #6)
> This doesn't actually seem to work -- e.g.
> 
> http://tests.themasta.com/tinderboxpushlog/?tree=MozillaTry&rev=15e65c1f91da
> doesn't show any results, even though the push certainly happened.

It only shows the push if it's in the time range that would be displayed without the rev argument. Automatically going back into time isn't implemented yet.
Product: Webtools → Tree Management
Product: Tree Management → Tree Management Graveyard
You need to log in before you can comment on or make changes to this bug.