Last Comment Bug 598601 - Page does not take focus from form fields when page clicked at far left of screen
: Page does not take focus from form fields when page clicked at far left of sc...
Status: RESOLVED DUPLICATE of bug 599681
:
Product: Core
Classification: Components
Component: Layout: View Rendering (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-22 04:55 PDT by DavidC
Modified: 2010-09-29 09:35 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description DavidC 2010-09-22 04:55:16 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100921 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100921 Firefox/4.0b7pre

If cursor focus is in a a form field and cursor is then moved to far left of screen when browser is maximised, focus is not given to the page as expected.

Reproducible: Always

Steps to Reproduce:
1. create a new profile

2. the initial Minefield feedback screen - http://www.mozilla.org/projects/firefox/prerelease.html - is displayed

3. maximize Minefield

4. place cursor in 'Name' form field and left click for focus

5. move cursor so that it's touching left side of screen and left click

6. focus remains in the form input field instead of focusing the page
Actual Results:  
Focus remains in form field.

Expected Results:  
Focus should be given to page.
Comment 1 Csaba Kozák [:WonderCsabo] 2010-09-22 05:02:19 PDT
Confirmed.
Comment 2 Alice0775 White 2010-09-22 05:43:24 PDT
When I disable MenuBar auto hide(i.e always show MenuBar), this problem does not happen.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100921 Firefox/4.0b7pre ID:20100921041551
Comment 3 Csaba Kozák [:WonderCsabo] 2010-09-22 05:47:04 PDT
You should try with brand new fresh profile.
Comment 4 DavidC 2010-09-22 05:51:16 PDT
Alice0775 White:

> When I disable MenuBar auto hide(i.e always show MenuBar), this problem does
not happen.

Confirmed.

~~~

Csaba Kozák [:WonderCsabo]:

> You should try with brand new fresh profile.

This is with new profile. If you always display Menu Bar the problem I described does not happen.
Comment 5 Csaba Kozák [:WonderCsabo] 2010-09-22 05:54:08 PDT
Confirmed!

The focus is wrong only with Fx button (menu bar disabled)
Comment 6 Alice0775 White 2010-09-22 06:28:38 PDT
I tried to find regression range in local build. and I found.
This caused by checked in 7804b5cf4313 Robert O'Callahan — Bug 130078. Part 2. Remove widgets from all subframes
Comment 7 Csaba Kozák [:WonderCsabo] 2010-09-22 06:31:25 PDT
You should CC him.
Comment 8 Alice0775 White 2010-09-25 19:26:46 PDT
And this bug brake autoscroll aalong left edge.
1.Maxmize window,
2.Start Autoscroll by Middle click at any where
3.Move mouse at left edige and move mouse up/down along left edge
Comment 9 Mike Beltzner [:beltzner, not reading bugmail] 2010-09-28 22:22:37 PDT
Alice: in the future, when you find a regression specific to a bug, please:

 - add the regression keyword
 - add the regressing bug number to the "blocks" field
 - cc the reviewer, committer and bug owner of the regressing bug

thanks! your efforts are much appreciated!
Comment 10 Timothy Nikkel (:tnikkel) 2010-09-28 23:01:42 PDT
So if it only happens when we don't have the menubar then I think we are doing our own hit testing, so the bug would be in that hit testing code I would think.
Comment 11 Timothy Nikkel (:tnikkel) 2010-09-29 00:07:55 PDT
(In reply to comment #9)
> thanks! your efforts are much appreciated!

Seconded!
Comment 12 :Felipe Gomes (needinfo me!) 2010-09-29 09:35:44 PDT

*** This bug has been marked as a duplicate of bug 599681 ***

Note You need to log in before you can comment on or make changes to this bug.