Closed Bug 598617 Opened 10 years ago Closed 10 years ago

Alternate keyboard (SwiftKey) does not work correctly w/ Fennec

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: eric, Assigned: crowderbt)

References

Details

(Whiteboard: [VKB])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: 2.0b1pre (2010/09/21 nightly)

Entering text in Fennec w/ the SwiftKey keyboard does not work correctly.

SwiftKey available here:
http://www.appbrain.com/app/com.touchtype.swiftkey.trial

Reproducible: Always

Steps to Reproduce:
1. Open Fennec w/ SwiftKey enabled
2. Tap awesome bar
3. Try to enter a URL, like touch.facebook.com.
Actual Results:  
Hitting the "." will delete the "h"

Expected Results:  
Should be able to use alternate keyboards w/ Fennec w/ correct keyboard behavior.

Happens on other text inputs as well. Various keys don't work correctly.
Running HTC EVO4G w/ Stock Froyo ROM
OS: Other → Android
Hardware: Other → ARM
Flags: in-litmus?(nhirata.bugzilla)
Mozilla/5.0 (Android; Linux armv71; rv2.0b7pre) Gecko/20100927 Firefox/4.0b7pre Fennec/2.0b1pre

Confirmed with Swiftkey on Fennec.  Does not occur with Swiftkey on stock web browser.  Using Nexus 1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Alternate keyboard (SwiftKey) does not work correctly w/ Fennec → [VKB]Alternate keyboard (SwiftKey) does not work correctly w/ Fennec
Litmus test case created : 

https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=13541
tracking-fennec: --- → ?
Flags: in-litmus?(nhirata.bugzilla) → in-litmus+
tracking-fennec: ? → 2.0+
Summary: [VKB]Alternate keyboard (SwiftKey) does not work correctly w/ Fennec → Alternate keyboard (SwiftKey) does not work correctly w/ Fennec
Whiteboard: [VKB]
Assignee: nobody → crowderbt
Duplicate of this bug: 602852
New version of Swiftkey was just released that fixes this issue.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
If this was a SwiftKey bug, why was the Android browser not affected by it?
Brian, I don't have an answer for you, but I can confirm that it is fixed using their update and the latest nightly build of Fennec.

http://www.swiftkey.net/changelog.1.0.936.txt

- Firefox for Android cursor bug fixed
Verified/confirmed:
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101015 Firefox/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.