DIV after an LI renders with a superfluous line break

VERIFIED DUPLICATE of bug 36854

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 36854
18 years ago
18 years ago

People

(Reporter: Wayne Davison, Assigned: Pierre Saslawsky)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
If a LI tag is immediately followed by a DIV tag, the bullet item is followed by
an empty line.  All the other browsers I've tried (including NS 4.75, IE 5.5,
and Konqueror 1.9.8) do not render this empty line.
I am guessing that this is invalid because <div> is a block-level element and so
should be rendered as you see it rendered.

Reassigning to style system for evaluation.
Assignee: clayton → pierre
Component: HTML Element → Style System
QA Contact: lorca → chrisd

Comment 2

18 years ago
Created attachment 19129 [details]
Testcase

Comment 3

18 years ago
See also bug 1049.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Linux → All
I think this is a layout problem.  I think 'list-style-position: inside' bullets
are causing new lines to be created when they don't need to be.  (The spec is
vague here, but the behavior should be consistent with 'outside'.)

I don't see any problems in part 3 of the testcase.

*** This bug has been marked as a duplicate of 36854 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified duplicate of bug 36854.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.