Closed Bug 598680 Opened 11 years ago Closed 11 years ago

The input type="file" control does not get styled

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 52500

People

(Reporter: shivk, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

The html form control
<input type="file"/>
does not respect CSS styles. So if you set border, radius background image etc. none of that shows and the control appears like the old sunken 3D look.

Reproducible: Always

Steps to Reproduce:
Simply put an <input type="file"> control on a form and style is using CSS

I've used the following style
		  input {			
			  border:1px solid #ccc;
			  font-size:20px;			
			  padding: 5px 10px 5px 10px;			
			  border-radius:10px;
			  -moz-border-radius: 10px;			
		  }

Actual Results:  
The control appears as if it was not styled at all and looks like the old sunken 3D look.

Expected Results:  
I'd expect the control to appear styled like other input elements.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: input[type=file]
v.
Status: RESOLVED → VERIFIED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.