If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Addon Bar should be bottom of Toolbar contextual menu, currently it's top

RESOLVED FIXED in Firefox 4.0b7

Status

()

Firefox
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Paul [pwd], Assigned: dietrich)

Tracking

Trunk
Firefox 4.0b7
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre

Currently should you right click on the Navigation bar, you'll see "Addon Bar" at the top. Above Menu Bar, Navigation Bar and Bookmarks Toolbar. It should be at the bottom of that list.

Reproducible: Always
(Reporter)

Updated

7 years ago
Blocks: 574688
Version: unspecified → Trunk
(Assignee)

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

7 years ago
Assignee: nobody → dietrich
(Assignee)

Comment 1

7 years ago
Created attachment 479774 [details] [diff] [review]
v1
Attachment #479774 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #479774 - Flags: review? → review?(dao)
Comment on attachment 479774 [details] [diff] [review]
v1

>+  let addonBar = null;
>   let toolbarNodes = [document.getElementById("addon-bar")];
>   for (i = 0; i < gNavToolbox.childNodes.length; ++i)
>     toolbarNodes.push(gNavToolbox.childNodes[i]);
>   toolbarNodes.forEach(function(toolbar) {

Seems like this should just be something like this:

let toolbarNodes = Array.slice(gNavToolbox.childNodes);
toolbarNodes.push(document.getElementById("addon-bar"));
Attachment #479774 - Flags: review?(dao) → review-
(Assignee)

Comment 3

7 years ago
not sure if slice() will work there because childNodes is a nodelist not a regular js array. but i'll give it a try!
(Assignee)

Comment 4

7 years ago
Created attachment 480071 [details] [diff] [review]
v1.1

works!
Attachment #479774 - Attachment is obsolete: true
Attachment #480071 - Flags: review?(dao)
Comment on attachment 480071 [details] [diff] [review]
v1.1

With the slice/push change, why is the rest of this patch needed? r- because this doesn't seem to make sense, please re-request if I'm missing something.
Attachment #480071 - Flags: review?(dao) → review-
(Assignee)

Comment 6

7 years ago
Created attachment 480117 [details] [diff] [review]
v1.2

right, not needed
Attachment #480071 - Attachment is obsolete: true
Attachment #480117 - Flags: review?(dao)
Comment on attachment 480117 [details] [diff] [review]
v1.2

>-  var i;
>-
>   // Empty the menu
>-  for (i = popup.childNodes.length-1; i >= 0; --i) {
>+  for (var i = popup.childNodes.length-1; i >= 0; --i) {

You could replace var with let while you're at it.
Attachment #480117 - Flags: review?(dao) → review+

Updated

7 years ago
blocking2.0: --- → ?

Updated

7 years ago
Attachment #480117 - Flags: approval2.0?
blocking2.0: ? → -
Attachment #480117 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/286e78ac1ba1
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8

Updated

7 years ago
Target Milestone: Firefox 4.0b8 → Firefox 4.0b7
You need to log in before you can comment on or make changes to this bug.