File with exclusive lock when uploaded via drag and drop to GMail

RESOLVED DUPLICATE of bug 578096

Status

()

--
major
RESOLVED DUPLICATE of bug 578096
8 years ago
8 years ago

People

(Reporter: antares.pt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ImageShackToolbar/5.2.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ImageShackToolbar/5.2.4

When composing an e-mail and I use the drag-n-drop of a attachment of a file from the disk to gmail, Firefox gets an exclusive lock of the file. Even after sending the e-mail. I have to close the tab where I've been using gmail to get exclusive lock of the file.

Reproducible: Always

Steps to Reproduce:
1.Open Gmail
2.Compose a e-mail
3.Drap-n-drop a file into gmail and send the e-mail
4.Try to move or delete the file you attached on step 3


Actual Results:  
I can delete, move or overwrite the file from the disk once I used it in an attachment.
(Reporter)

Comment 1

8 years ago
In "Actual Results:" it should be read:

I **can't** delete, move or overwrite the file from the disk once I used it in an
attachment.

Comment 2

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

Able to reproduce. Tested in the latest release build and also earlier 3.6.x versions and latest 4.x beta releases. 
After Step 3, unable to move or delete the file. Received an Error : "The action can't be completed because the file is open in firefox". 
Files attached through "Attach a file" link works fine.
OS: Windows 7 → All
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578096
You need to log in before you can comment on or make changes to this bug.