[IE 6] Images aren't transparent and look bad in Internet Explorer 6

VERIFIED FIXED

Status

VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 478111 [details]
Screenshot of IE 6

See screenshot of IE 6 on http://www-trunk.stage.mozilla.com/en-US/mobile/beta/
(Reporter)

Updated

8 years ago
Blocks: 596853
I am not sure being IE6 compatible is necessary for a beta section that is targetting early adopters, maybe we can check what the % of IE6 users we get to this beta page to see if it is worth dedicating time on that?
Weird - r74850 should have fixed this, and it does look fixed on my dev server in an IE6 VM. Can't figure out why the PNG fix isn't working on stage
FWIW, the Firefox beta page has this same issue:

http://www-trunk.stage.mozilla.com/en-US/mobile/beta/

It's not as noticeable because the images have a background color close to the page gradient bg, but the "Give Feedback" image has a white background. Not sure where that feedback thing came from though.

I'll try to figure out why my dev box shows the issue fixed when stage doesn't, but in the meantime I think I'll try changing the image BG colors as a bandaid fix
Okay, I think r74890 fixes this on stage. Got rid of the iepngfix workaround and just reexported the images as 8-bit indexed PNGs, which are slightly lower quality but seem to make IE6 happier
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

8 years ago
Verified FIXED; tested in IE 6, 7, 8; thanks!
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.