[Add-ons Bar] Turn the statusbar element into a toolbar widget (or wrap it in one)

RESOLVED DUPLICATE of bug 607048

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 607048
8 years ago
8 years ago

People

(Reporter: Matthew Turnbull [Bluefang], Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon bar][target-betaN])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre

The Add-ons Bar seems to be there as a place for add-ons to put their status icons. To that end, the Add-ons Bar tries to act like the "system tray" rather than a toolbar.

However, the statusbar/statusbarpanel paradigm seems to work perfectly fine for that, and I see no reason to replace it.


So, my suggestion would be to turn the statusbar element in to a "Status-Bar" toolbar widget (or wrap it in one), and have that be the proper place to have status icons. This way, there's no change from the classic status-bar, contextually or add-on implementation-wise. However, now the user can place these status icons/controls anywhere in the UI they desire.

Then treat the Add-ons Bar as a regular toolbar (though maybe locked in 'small icons' mode), and have the default widgets be [Flexible Spacer][Status-Bar]

Reproducible: Always
(Reporter)

Updated

8 years ago
Depends on: 574688
Version: unspecified → Trunk

Comment 1

8 years ago
You might wanna add bug 598929 to the depends on list.

Comment 2

8 years ago
your assumption is wrong:

the “status icons” added to the addon bar will work like toolbar buttons: they can be individually moved whereever the user wants them to be.

the current solution of adding old-style overlay icons to the <statusbar/> inside the addon bar ist just a *temporary* compatibility hack which is there not to break the addons using these overlays.

changing a container of moveable buttons into being moveable itself is pretty pointless.
(Reporter)

Comment 3

8 years ago
Well, then the statusbar element needs to act more like a toolbar item in that you should be able to place items to the left of it.

My point was that the addon-bar should act like a regular toolbar (it doesn't in a number of ways) and the statusbar element should not hinder the placement of toolbar items (which it does).

Yes, I realize the statusbar element is meant to be temporary. But how temporary is 'temporary'? Will it be gone by 4.0? If not, then it needs to play nice on the toolbar. Being able to move it to another toolbar would be a bonus. Say I have 1 extension that still uses it. In order to see it's icon, I need to have the entire, nearly empty addon-bar showing. That's an awful lot of wasted space, especially when I have plenty of space on my other toolbars to put it.
Whiteboard: [addon bar]
Depends on: 607048

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
No longer depends on: 607048, 574688
Resolution: --- → DUPLICATE
Duplicate of bug: 607048
Whiteboard: [addon bar] → [addon bar][target-betaN]
You need to log in before you can comment on or make changes to this bug.