Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 368203
7 years ago
7 years ago

People

(Reporter: rstrong, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

It is difficult for bug reporters to provide all of the files and info needed when they have filed an app update bug and it is difficult to convey the steps to provide this information. To simplify this I would like to add a hidden preferences that will log all app update messages to a file and include the active-update.xml, updates.xml, update.status, update.log, last-update.log, and backup-update.log into a single file in the profile. The logging would be controlled by a counter so it will automatically deactivate after x number of runs.

Henrik, thought you might be interested in this.
Sounds good! Would it also include the final url of the mirror we are downloading the update from? When will the log file get emptied or older data removed?
The final url is in the active-update.xml and updates.xml so it will be included. The logs will most likely be removed when the counter finishes counting down with the last couple of decrements of the counter not doing anything so the user can get a hold of the logs before they are deleted.
Ok, so only one more question for now. What about multiple updates in a row? Something we also had lately like Beta X build 1 -> Beta X build 3 -> Beta Y build 1? Will the log get reset before the second update?
It won't. The counter will save x number of the data from the updates (not the mar itself though) in a row where I haven't decided yet what x will be. I haven't yet decided upon how it will save it yet though it will most likely either be in a log file or in separate directories within a zip.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 368203
You need to log in before you can comment on or make changes to this bug.