Closed Bug 599297 Opened 11 years ago Closed 11 years ago

Advanced add/remove engine functions for search sidebar

Categories

(SeaMonkey :: Search, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 595246

People

(Reporter: YohanPRC, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; zh-CN; rv:1.9.1.13) Gecko/20100914 SeaMonkey/2.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; zh-CN; rv:1.9.1.13) Gecko/20100914 SeaMonkey/2.0.8

There are 3 engines (Google, dMoz and Ask.com) in Sidebar Search, and user can add a custom engines by Sherlock. But it's still too unfriendly to users to add or remove engines. 

To add a CUSTOM engine, the user must edit an Sherlock ".src" file and make a corresponding HTML and open it in SeaMonkey. 

Hardly can anybody remove engines from the engine-list unless edit the user profile (simply ramove it from a "category" is not the right method). 

See "Expected Results" section.

Reproducible: Always



Expected Results:  
1. Add an "add new" button in the search sidebar, to let the user designate several parameters (simple/advanced) to add an engine. 

2. Add an "add exist" button to bring the user to Mycroft Project. 
   (there're already similar actions in Mozilla: the "find more tabs" brings the user to http://dmoz.org/Netscape/Sidebar/, which is a defunct website)

3. Add an "remove" button to remove certain engine from "All Search Engines", rather than a category.

The first and third Expected Results can be performed by add an "All Search Engine"-item in the "Category"-combo-box in the "Edit category"-dialog of the Sidebar Search.
Component: Sidebar → Search
QA Contact: sidebar → search
Summary: Fragmentary Sidebar Search - No "visible" add/remove functions → Advanced add/remove engine functions for search sidebar
Issue #1: Install Search Engine Wizard extension from:
http://xsidebar.mozdev.org/modifiedmisc.html#searchenginewizard
Open the search webpage, righ-click on the input field of keywords, and click "Add Search-plugin".

Issue #3: Install the Advanced Search Sidebar extension from:
http://xsidebar.mozdev.org/modified.html#advancedsearch
This adds a new sidebar called Advanced Search similar to the existing search sidebar except that it has a "Delete" option in the context menu if you right-click on a search engine.
(In reply to comment #1)
> Issue #1: Install Search Engine Wizard extension from:
> http://xsidebar.mozdev.org/modifiedmisc.html#searchenginewizard
> Open the search webpage, righ-click on the input field of keywords, and click
> "Add Search-plugin".
> 
> Issue #3: Install the Advanced Search Sidebar extension from:
> http://xsidebar.mozdev.org/modified.html#advancedsearch
> This adds a new sidebar called Advanced Search similar to the existing search
> sidebar except that it has a "Delete" option in the context menu if you
> right-click on a search engine.

Issue #1:

1. Add new engine should be a basic feature that should not be implement by Add-ons; 

2. The add-on helps users to add engine in a WYSIWYG-way, and the WYSIWYG-way is an advanced feature and should be implement by Add-ons. A simple field-input add-engine dialog is a basic feature. So with issue 1, the add-on did different things, and does not solve the problem. 

3. Currently, the add-on "Search Engine Wizard" seems to be dying since the link https://addons.mozilla.org/seamonkey/addon/2206/ is not available.
(In reply to comment #1)
> Issue #1: Install Search Engine Wizard extension from:
> http://xsidebar.mozdev.org/modifiedmisc.html#searchenginewizard
> Open the search webpage, righ-click on the input field of keywords, and click
> "Add Search-plugin".
> 
> Issue #3: Install the Advanced Search Sidebar extension from:
> http://xsidebar.mozdev.org/modified.html#advancedsearch
> This adds a new sidebar called Advanced Search similar to the existing search
> sidebar except that it has a "Delete" option in the context menu if you
> right-click on a search engine.

Issue #3:

1. The Advanced Search Sidebar (Firefox Search Sidebar project) is nothing but a toy since the so-called "Search Sidebar" does not shown your search results in the sidebar. Also, it does not have additional features such as "merge search results" in SeaMonkey. At least, when I tried it in Firefox today, it does not. 

2. Delete an engine is also a basic feature - CAN IMAGINE A BROWSER THAT CANNOT REMOVE BOOKMARKS AND SAY "PLEASE INSTALL AN ADD-ON IF YOU WANT TO REMOVE ANY BOOKMARK YOU ADDED"?
Stop using all capitals here or we'll resolve this bug as invalid and get you banned from Bugzilla as you're going against the etiquette: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

That said, the sidebar displaying scraped search results is interesting but unfortunately something that will go away as it works worse and worse and doesn't play well with the better customizable search plugin solution we're adopting (OpenSearch). On the upside, the currently somewhat bad management for removing search engines will work better there (though that management might not make 2.1 Beta 1, I hope we'll get it soon after and for the final version).
(In reply to comment #4)
> Stop using all capitals here or we'll resolve this bug as invalid and get you
> banned from Bugzilla as you're going against the etiquette:
> https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
> 
> That said, the sidebar displaying scraped search results is interesting but
> unfortunately something that will go away as it works worse and worse and
> doesn't play well with the better customizable search plugin solution we're
> adopting (OpenSearch). On the upside, the currently somewhat bad management for
> removing search engines will work better there (though that management might
> not make 2.1 Beta 1, I hope we'll get it soon after and for the final version).

I've taken a look of Bugzilla Etiquette but di NOT see any guidelines inquiring me not to use all capitals. Plus, they're merely guidelines, and you have no rights to ban me from Bugzilla.
(In reply to comment #4)
> Stop using all capitals here or we'll resolve this bug as invalid and get you
> banned from Bugzilla as you're going against the etiquette:
> https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
> 
> That said, the sidebar displaying scraped search results is interesting but
> unfortunately something that will go away as it works worse and worse and
> doesn't play well with the better customizable search plugin solution we're
> adopting (OpenSearch). On the upside, the currently somewhat bad management for
> removing search engines will work better there (though that management might
> not make 2.1 Beta 1, I hope we'll get it soon after and for the final version).

The sidebar displaying scraped search results works worse and worse because we did never tried to improve it, the nowaday sidebar search is exactly the same as 5 years ago. And plus, it's fragmentary, so I put this bug here. I don't think this should be a reason for us to give up the scraped search results function. 

It seems that the OpenSearch and Sherlock do not offer any information about “scraped search results” or “combined search results”, but as we know, the internal-based engine Google, supports. So there is a hidden structure of this technology, even-though it's not available to the user. What we need to do is simply make the hidden structure available to the users, and bring it out as a "protocol", say "Advanced OpenSearch" or something. 

Indeed, this might need supports from search engine providers - to implement this function, the search engine providers should offer their search results in a database-like way, in order to let any two search results from different engine could be merged. Yet still we have chances to let the sidebar search reborn. We have that ability to do it and it is useful (Google has tried to do that - in the newest version of Googlebar for IE8 there's a sidebar search to substitude the original "google.com/ie" sidebar search).
(In reply to comment #6)
> What we need to do is
> simply make the hidden structure available to the users

Feel free to implement that on top of the work we are doing for OpenSearch support, but our team as it is is too small to work on that. Once you have a working implementation, we can talk about integrating it. I'd advise you develop it as an add-on first so you can immediately make it accessible to people.
BTW, "the work we are doing for OpenSearch support" is bug 410613 as the first step. Please don't comment about what you describe in here over in the other bug, as anything suggested here can only be a followup step/bug from the one there.
(In reply to comment #7)
> (In reply to comment #6)
> > What we need to do is
> > simply make the hidden structure available to the users
> 
> Feel free to implement that on top of the work we are doing for OpenSearch
> support, but our team as it is is too small to work on that. Once you have a
> working implementation, we can talk about integrating it. I'd advise you
> develop it as an add-on first so you can immediately make it accessible to
> people.

I'm not currently a developer now so I don't think I'm eligible to do that now. But question: now that we can't achieve that because our team "is is too small to work on that", why do we mark the already-exist scraped search results feature for Google as "something that will go away" and removed it from SeaMonkey 2.1 Beta 1 Nightly? 

I'm confusing: if the only scraped search results feature is removed, why do we keep the sidebar search here? Simply remove it and build a Firefox-like searchbar is better.
(In reply to comment #8)
> BTW, "the work we are doing for OpenSearch support" is bug 410613 as the first
> step. Please don't comment about what you describe in here over in the other
> bug, as anything suggested here can only be a followup step/bug from the one
> there.

Thank you. When I posted that comment I hadn't post this bug. And that is not related to this bug. In fact, from comment #4, comment #6 and comment #7 is talking about a new bug - “should the ‘scraped search results’ be keeped?” While the bug 599297 is, “no add/remove engine functions available for search sidebar”.
(In reply to comment #9)
> why do we mark the already-exist scraped search results
> feature for Google as "something that will go away" and removed it from
> SeaMonkey 2.1 Beta 1 Nightly? 

Because that feature doesn't work work with the OpenSearch code we want to adapt as the amount of Mycroft plugins (current solution) compared to OpenSearch+Mycroft plugins (new solution) is rapidly decreasing. The old solution is just not good enough for the average user any more and not extensible with current standards. Also, our current code hasn't been maintained for multiple years, and having code around that is ugly and unmaintained is nothing we want to have.

> I'm confusing: if the only scraped search results feature is removed, why do we
> keep the sidebar search here? Simply remove it and build a Firefox-like
> searchbar is better.

I won't discuss the overall plan of SeaMonkey search in a not directly related bug. Also, there are interesting possibilities to extend the minimal sidebar we'll have for the moment. Still, all not the right topic for this bug report. If you want to discuss that, please take it to the newsgroups.
I think that we need the possibility to remove search engines, and AFAIK we currently don't have that on trunk. Whether we'll in the end have it in the sidebar only/additionally, or in a search widget like Firefox, or somewhere else, doesn't matter, we can still mark bugs as duplicates of others later. For now, this sounds like a plan, so confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
The WIP patch in bug 401417 contains an engine manager that allows this, so I guess it's worth marking this as a dependency. Note that we'd be very happy about someone picking up that patch, finishing it up and driving it into the tree.
Depends on: 401417
No longer depends on: 401417
(In reply to comment #13)
> The WIP patch in bug 401417 contains an engine manager that allows this, so I
> guess it's worth marking this as a dependency. Note that we'd be very happy
> about someone picking up that patch, finishing it up and driving it into the
> tree.

I don't this is depend on that patch, but merely related to a branch of that patch. This add/remove function is aimed at the traditional SEARCHBAR, not the SEARCHBOX.
Depends on: 595246
“the sidebar displaying scraped search results is interesting but
unfortunately something that will go away as it works worse and worse and
doesn't play well with the better customizable search plugin solution we're
adopting” - Did anyone posts this bug?
No longer depends on: 595246
This is a duplicate of bug 595246, which already states that there should be this functionality added for sidebar.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595246
This bug DOES NOT depeng on ANY one of bug 401417 and bug 410613, so unless bug 595246 is edited, this bug still remains active.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
The only parts of this we will work on is what bug 595246 is tracking. I'm a project manager of SeaMonkey, please respect what I'm setting those bugs to. If you want more info, please join us on the #seamonkey channel on IRC.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595246
You need to log in before you can comment on or make changes to this bug.