"Assertion failure: !vp->isPrimitive() && callee != &vp[0].toObject(),"

RESOLVED FIXED

Status

()

defect
--
critical
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: gkw, Assigned: luke)

Tracking

(Blocks 1 bug, {assertion, regression, testcase})

Trunk
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 beta8+)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment)

Reporter

Description

9 years ago
(function () {
    x = constructor
})()
new(x)(x)

asserts js debug shell on TM changeset 1c913526c597 without -m or -j at Assertion failure: !vp->isPrimitive() && callee != &vp[0].toObject(),
Reporter

Updated

9 years ago
blocking2.0: --- → ?

Updated

9 years ago
blocking2.0: ? → beta8+
Assignee

Comment 1

9 years ago
Posted patch fixSplinter Review
Again, its the overly-conservative 'forgot to set rval' assertion.  I still like the checking it provides, so I'll keep loosening it unless anyone thinks its too much trouble and we should just remove it.
Assignee: general → lw
Status: NEW → ASSIGNED
Attachment #478373 - Flags: review?(brendan)
Attachment #478373 - Flags: review?(brendan) → review+
Assignee

Comment 2

9 years ago
http://hg.mozilla.org/tracemonkey/rev/d680172d578f
Whiteboard: fixed-in-tracemonkey
Assignee

Comment 3

9 years ago
Duh, callees can be non-functions with construct-hook
http://hg.mozilla.org/tracemonkey/rev/e005076ad798
Reporter

Comment 4

9 years ago
autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   52720:66c8ad02543b
user:        Luke Wagner
date:        Mon Aug 16 12:35:04 2010 -0700
summary:     Bug 581263 - remove slow natives (r=waldo,mrbkap)
Blocks: 581263

Comment 5

9 years ago
http://hg.mozilla.org/mozilla-central/rev/d680172d578f
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Whiteboard: fixed-in-tracemonkey → fixed-in-tracemonkey[suspect-regress-ts_cold_generated_med]
A changeset from this bug was associated with a XP Ts, Cold MED Dirty Profile regression on Firefox. boo-urns :(

  Previous: avg 420.356 stddev 3.679 of 30 runs up to a9d1ad0bc386
  New     : avg 430.832 stddev 1.905 of 5 runs since a60414d076b5
  Change  : +10.475 (2.49% / z=2.847)
  Graph   : http://mzl.la/bZFaB3

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a9d1ad0bc386&tochange=a60414d076b5

The tag [suspect-regress-ts_cold_generated_med] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.
Assignee

Comment 7

9 years ago
Patch only changes assertion.
Whiteboard: fixed-in-tracemonkey[suspect-regress-ts_cold_generated_med] → fixed-in-tracemonkey

Updated

9 years ago
Whiteboard: fixed-in-tracemonkey → fixed-in-tracemonkey[suspect-regress-dromaeo_css]
A changeset from this bug was associated with a Win7 Dromaeo (CSS) regression on Firefox. boo-urns :(

  Previous: avg 2014.419 stddev 40.480 of 30 runs up to a9d1ad0bc386
  New     : avg 1901.610 stddev 12.432 of 5 runs since a60414d076b5
  Change  : -112.809 (-5.6% / z=2.787)
  Graph   : http://mzl.la/9gFu4n

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a9d1ad0bc386&tochange=a60414d076b5

The tag [suspect-regress-dromaeo_css] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.

Updated

9 years ago
Whiteboard: fixed-in-tracemonkey[suspect-regress-dromaeo_css] → fixed-in-tracemonkey[suspect-regress-dromaeo_css][suspect-regress-dromaeo_jslib]
A changeset from this bug was associated with a Win7 Dromaeo (jslib) regression on Firefox. boo-urns :(

  Previous: avg 127.610 stddev 4.222 of 30 runs up to a9d1ad0bc386
  New     : avg 116.384 stddev 0.751 of 5 runs since a60414d076b5
  Change  : -11.226 (-8.8% / z=2.659)
  Graph   : http://mzl.la/bZu5UP

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a9d1ad0bc386&tochange=a60414d076b5

The tag [suspect-regress-dromaeo_jslib] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.
A changeset from this bug was associated with a XP Dromaeo (CSS) regression on Firefox. boo-urns :(

  Previous: avg 2045.275 stddev 49.676 of 30 runs up to a9d1ad0bc386
  New     : avg 1936.120 stddev 13.937 of 5 runs since a60414d076b5
  Change  : -109.155 (-5.34% / z=2.197)
  Graph   : http://mzl.la/b0dlou

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a9d1ad0bc386&tochange=a60414d076b5

The tag [suspect-regress-dromaeo_css] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.
A changeset from this bug was associated with a XP Dromaeo (jslib) regression on Firefox. boo-urns :(

  Previous: avg 129.703 stddev 4.099 of 30 runs up to a9d1ad0bc386
  New     : avg 117.954 stddev 0.660 of 5 runs since a60414d076b5
  Change  : -11.749 (-9.06% / z=2.866)
  Graph   : http://mzl.la/avZij4

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a9d1ad0bc386&tochange=a60414d076b5

The tag [suspect-regress-dromaeo_jslib] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.
Assignee

Updated

9 years ago
Whiteboard: fixed-in-tracemonkey[suspect-regress-dromaeo_css][suspect-regress-dromaeo_jslib] → fixed-in-tracemonkey
Automatically extracted testcase for this bug was committed:

https://hg.mozilla.org/mozilla-central/rev/efaf8960a929
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.