App tab title change notification is sometimes hard to see, especially with aero glass/basic

NEW
Unassigned

Status

()

Firefox
Theme
8 years ago
3 years ago

People

(Reporter: gaby2300, Unassigned)

Tracking

({access, regression})

Trunk
x86
Windows 7
access, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100924 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100924 Firefox/4.0b7pre

The actual color of the changed of state App Tab is not noticeable enough, it should return to red as it originally was or orange. Or maybe it could the be an option?

Reproducible: Always

Steps to Reproduce:
1. Make the GMail, the Hotmail, or the Yahoo tabs into App Tabs.
2. Wait till you receive a new message.
Actual Results:  
The App Tab turns brighter with a very light bluish shade making it difficult to notice it has changed state.

Expected Results:  
The App Tab should turn red as it it did before, or orange as the Windows 7 notifications. Or else the color could be an option for the user to choose.
(Reporter)

Updated

8 years ago
Severity: normal → enhancement
Version: unspecified → Trunk

Updated

8 years ago
Blocks: 593339
Component: Tabbed Browser → Theme
QA Contact: tabbed.browser → theme

Comment 1

8 years ago
Since the background will change with glass, the best way to test this is to stack up your Fx window with a bunch of other maximized Fx glass windows behind it.  I agree that red was subtle enough but more visible.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Since the background will change with glass, the best way to test this is to
> stack up your Fx window with a bunch of other maximized Fx glass windows behind
> it.  I agree that red was subtle enough but more visible.

Do you mean I have to keep several windows open at the same time? If so, what about the RAM's and the memory's use?

Red was much more visible! I don't want to keep open several windows a t the same time when there's a much simpler solution: go back to red or change it to orange as all Windows 7 notifications! Or at least let the color be a user's option!

It's very important for me to be aware of some app tab's change of state!
I agree, the blue is too subtle when the environment is already blue-ish.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Keywords: regression
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> I agree, the blue is too subtle when the environment is already blue-ish.

It's good to know you agree!
Perhaps you being a Mozilla person makes devs take heed of the issue!

Comment 5

8 years ago
I think this is a problem not only on Win 7 but with every platform. If you have a theme with light blue color you can see it. On Win XP I'm experiencing this: the color _is very difficult to notice_.
For now I've solved adding the previous deleted code in the userChrome.css file in order to restore the red color:

.tabbrowser-tab[pinned][titlechanged]:not([selected="true"]) {
    background-image: -moz-linear-gradient(rgba(255,0,0,.5), rgba(255,0,0,.5)) !important;
}

but IMHO this should be fixed because adding "mysterious" code to a file "hard to find" isn't the solution for every user.

Would be nice if FF would use two contrasting color for the gradient because white and the actual light blue aren't.
In general would be more effective if FF would recognize the background color and would choose the right color for the tab between two different colors, but I see, maybe this is unnecessarily complicated.
This bug feels bikesheddy - I notice the highlight just fine on my Vista box, but this is a call for the theme master. Shorlander - we blocking or no?
(In reply to comment #6)
> This bug feels bikesheddy - I notice the highlight just fine on my Vista box,
> but this is a call for the theme master. Shorlander - we blocking or no?

Not blocking and should probably be WONTFIX since there are no plans to revert the appearance.
You can WONTFIX if you like, this is your bailiwick. I'll minus the nom, though.
blocking2.0: ? → -
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 9

8 years ago
I'm really sorry to see this wont be fixed because as it is I can hardly see the highlight in my Windows 7 with Aero enabled. 
I think you should at least make it optional so the user would be able to leave the default colour or change it to red (as it was before) or to orange as all the Windows notifications.
(In reply to comment #6)
> This bug feels bikesheddy - I notice the highlight just fine on my Vista box,

There's no uniform Vista environment, background colors vary. There's personas too.

> WONTFIX since there are no plans to revert the appearance.

We may not have plans, but WONTFIX means we would under no circumstances accept a patch, which seems false. This bug isn't about /reverting/ the appearance either. The red styling was a placeholder and obviously won't be restored.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

8 years ago
Status: REOPENED → NEW
Created attachment 487597 [details]
screenshot

Here's what I see on Win 7. It's noticeable (for my eyes) if you know what you're looking for. It's a bit like the now-removed open search notification; I suspect many users will perceive it as an artifact and ignore it.

Updated

8 years ago
Severity: enhancement → normal
Keywords: access
Summary: Change the color of the change of state [Bug 577096] App Tabs should indicate change of state in <title> → App tab title change notification is sometimes hard to see, especially with aero glass/basic
(Reporter)

Comment 12

8 years ago
Ah, yes! It's noticeable if you know what you're looking for or if you keep checking for the change. But if you get lost working online on something else it could go completely unnoticed for quite a while. This isn't very useful because some users need to be aware of the change as soon as it's made.
(Reporter)

Comment 13

8 years ago
Ah, yes! It's noticeable if you know what you're looking for or if you keep
checking for the change. But if you get lost working online on something else
it could go completely unnoticed for quite a while. This isn't very useful
because some users need to be aware of the change as soon as it's made.
BTW, if you suspect many users will perceive it as an artifact and ignore it, then surely it needs to be changed for a less subtle shade or color?

Comment 14

8 years ago
(In reply to comment #11)
> Created attachment 487597 [details]
> screenshot
> 
> Here's what I see on Win 7. It's noticeable (for my eyes) if you know what
> you're looking for. It's a bit like the now-removed open search notification; I
> suspect many users will perceive it as an artifact and ignore it.
Isn't that why the search notification was removed?

(In reply to comment #13)
> Ah, yes! It's noticeable if you know what you're looking for or if you keep
> checking for the change. But if you get lost working online on something else
> it could go completely unnoticed for quite a while. This isn't very useful
> because some users need to be aware of the change as soon as it's made.

Happens to me all day everyday.  I do not notice the blue even when I look at the tab bar to change tabs.  I have to stare at my each individual app tab to even notice if state has changed.
(Reporter)

Comment 15

8 years ago
(In reply to comment #14)
> (In reply to comment #11)
> > Created attachment 487597 [details] [details]
> > screenshot
> > 
> > Here's what I see on Win 7. It's noticeable (for my eyes) if you know what
> > you're looking for. It's a bit like the now-removed open search notification; I
> > suspect many users will perceive it as an artifact and ignore it.
> Isn't that why the search notification was removed?
> 
> (In reply to comment #13)
> > Ah, yes! It's noticeable if you know what you're looking for or if you keep
> > checking for the change. But if you get lost working online on something else
> > it could go completely unnoticed for quite a while. This isn't very useful
> > because some users need to be aware of the change as soon as it's made.
> 
> Happens to me all day everyday.  I do not notice the blue even when I look at
> the tab bar to change tabs.  I have to stare at my each individual app tab to
> even notice if state has changed.

Sadly, as per comment #10 it seems it won't be changed. I don't think WONTFIX it's a good result at all though. 
I still insist it should be changed to orange as all Windows 7 notifications or at least be made an option because users with impaired eyesight surely can't notice the change at all!

Comment 16

7 years ago
I can attest to this being an a11y issue for vision impaired individuals.  I was hoping for some kind of about:config preference or something to control the color as it's very difficult for me to distinguish the limited contrast difference between notified and non-notified app tabs.  That said, the workaround in comment 5 did exactly what I needed.  I'd just like to see this option more easily discoverable in the future.
(Reporter)

Comment 17

7 years ago
(In reply to comment #5)
 
adding the previous deleted code in the userChrome.css file
in order to restore the red color:
 
.tabbrowser-tab[pinned][titlechanged]:not([selected="true"]) {
     background-image: -moz-linear-gradient(rgba(255,0,0,.5), rgba(255,0,0,.5))
 !important;
 }
 
Could you please guide me into going the above? 
I would really appreciate it because as stated in Comment 16, it's very difficult for me to distinguish the limited contrast difference between notified and non-notified app tabs.

Many thanks!

Comment 18

7 years ago
(In reply to comment #17)

> Could you please guide me into going the above? 

You have to search your Firefox profile folder:

http://support.mozilla.com/en-US/kb/Profiles

here should exist a folder "chrome" and inside it the file userChrome.css.
If they don't exist (one or both), create them.

Copy and paste the mentioned code, save the file and restart Firefox.

See also: http://kb.mozillazine.org/UserChrome.css

Obvious things (I apologize for this):
the userChrome.css file has to be modified with a *text editor* and not with a word processor; on Windows, be sure that the filenames extension is enabled; in case of problems you can ask/search on forums e.g. http://forums.mozillazine.org/index.php
(Reporter)

Comment 19

7 years ago
(In reply to comment #18)
> (In reply to comment #17)
> 
> > Could you please guide me into going the above? 
> 
> You have to search your Firefox profile folder:
> 
> http://support.mozilla.com/en-US/kb/Profiles
> 
> here should exist a folder "chrome" and inside it the file userChrome.css.
> If they don't exist (one or both), create them.
> 
> Copy and paste the mentioned code, save the file and restart Firefox.
> 
> See also: http://kb.mozillazine.org/UserChrome.css
> 
> Obvious things (I apologize for this):
> the userChrome.css file has to be modified with a *text editor* and not with a
> word processor; on Windows, be sure that the filenames extension is enabled; in
> case of problems you can ask/search on forums e.g.
> http://forums.mozillazine.org/index.php

Many thanks for answering me so soon!
I found 2 userChrome-example.css files in my profile. I erased it's contenet and I copied

.tabbrowser-tab[pinned][titlechanged]:not([selected="true"]) {
    background-image: -moz-linear-gradient(rgba(255,0,0,.5), rgba(255,0,0,.5))
!important;
}

into it. I saved the file and restarted Firefox but it didn't work. I have several Firefox profiles, do I have to do this procedure in all of them for this to work?

Comment 20

7 years ago
The userChrome-example.css is just that, an example.  You need to rename the file to userChrome.css and restart Firefox for it to have any effect.  You will need to do it for each profile.
(Reporter)

Comment 21

7 years ago
I hadn't renamed the file correctly. Now I have and it's working fine!
Many thanks for your help, I really appreciate it!

Updated

7 years ago
Duplicate of this bug: 616855
(Reporter)

Comment 23

7 years ago
(In reply to Decathlon from comment #5)
> I think this is a problem not only on Win 7 but with every platform. If you
> have a theme with light blue color you can see it. On Win XP I'm
> experiencing this: the color _is very difficult to notice_.
> For now I've solved adding the previous deleted code in the userChrome.css
> file in order to restore the red color:
> 
> .tabbrowser-tab[pinned][titlechanged]:not([selected="true"]) {
>     background-image: -moz-linear-gradient(rgba(255,0,0,.5),
> rgba(255,0,0,.5)) !important;
> }
> 
> but IMHO this should be fixed because adding "mysterious" code to a file
> "hard to find" isn't the solution for every user.
> 
> Would be nice if FF would use two contrasting color for the gradient because
> white and the actual light blue aren't.
> In general would be more effective if FF would recognize the background
> color and would choose the right color for the tab between two different
> colors, but I see, maybe this is unnecessarily complicated.

The added code isn't working in the newest Aurora builds. It was working fine in the 2 or three days ago builds! Any ideas? I would really appreciate them because I find the normal colour change almost impossible to note. Thanks!
You need to log in before you can comment on or make changes to this bug.