Closed Bug 599529 Opened 9 years ago Closed 9 years ago

Form helper moves input fields out of view

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0b3+)

VERIFIED FIXED
Tracking Status
fennec 2.0b3+ ---

People

(Reporter: cjones, Assigned: vingtetun)

References

Details

(Whiteboard: [fennec-checkin-postb2])

Attachments

(1 file)

STR
 (1) Go google.com, make sure using instant version
 (2) Type two characters into input box

Expected results: focused input field stays in view after the page transforms into the results display.

Actual results: view doesn't change after page morphs, input box goes out of view.
FWIW this works on desktop, so I suspect it would probably work with a physical keyboard, but I'm hitting another crasher bug on my N900.
Flags: in-litmus?(nhirata.bugzilla)
I can also reproduce this on http://people.mozilla.com/~cjones/input-large.html.  The input box is focused correctly, but when I enter the first character, the display jumps to what looks to be approximately <0, 100> judging by the grid.
If a fix for this is imminent, I'd really like to have it in b1.  With other input bugs fixed this is starting to stick out.  This bug unfortunately also tickles the old problem where the content can't be scrolled up even though there's more available, and the URL bar is pulled in instead.

STR for the latter problem
 (1) Navigate to bing.com (make sure it's the desktop version)
 (2) Unfocus the input box
 (3) Focus the input box

After focusing and zooming in on the text box, there's a jump to the bottom of the page, and subsequent attempts to pan back to the input box are blocked and the URL bar is pulled down instead.
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0+
Summary: Form field display, VKB, and Google Instant don't get along → [VKB]Form field display, VKB, and Google Instant don't get along
Summary: [VKB]Form field display, VKB, and Google Instant don't get along → Form field display, VKB, and Google Instant don't get along
Whiteboard: [VKB]
This isn't VKB only.  I see the same problems on http://people.mozilla.com/~cjones/input-large.html on my n900.

Another related bug on my n900 is
 (1) Focus the input field
    -- it jumps out of view --
 (2) Scroll the input field back into view (comment 3)
 (3) Enter any character on the HW keyboard

After (3), the field jumps out of view again.  I suspect these are all the same family of bugs so I won't file another.

IMHO this should block beta2.
Summary: Form field display, VKB, and Google Instant don't get along → Form helper moves input fields out of view
tracking-fennec: 2.0+ → 2.0b3+
Assignee: nobody → 21
Attached patch PatchSplinter Review
Our usual ignore "scroll" events while doing something hack.
Mark, you were right last time, we need to ignore them while the form helper is shown...
Attachment #487234 - Flags: review?(mark.finkle)
Removed the [VKB] whiteboard tag since this is not VKB related
Whiteboard: [VKB]
Comment on attachment 487234 [details] [diff] [review]
Patch

We need to be careful with the scrollSync API. It is not ref-counted, so it's easy for it to become out-of-sync if two parts of the code are trying to call it at different times.
Attachment #487234 - Flags: review?(mark.finkle) → review+
Whiteboard: [fennec-checkin-postb2]
http://hg.mozilla.org/mobile-browser/rev/76f8e7e9cdb2
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I am still seeing this on 

Mozilla/5.0(Android; Linux armv7l;rv2.0b8pre) Gecko/20101102 Firefox/4.0b8pre
Fennec/4.0b3pre

The google search bar hides itself on the top. I cannot see what I have typed in the search bar
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I think you're testing on today's build while the patch has landed a few hours ago. I'm closing this bug again but please don't hesitate to re-open it again if it's not working tomorrow.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101103 Firefox/4.0b8pre Fennec/4.0b3pre

Placing the device in portrait view, the textbox is half out of view.
Verified on :
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101105 Firefox/4.0b8pre
Fennec/4.0b3pre
Status: RESOLVED → VERIFIED
Flags: in-litmus?(nhirata.bugzilla) → in-litmus+
You need to log in before you can comment on or make changes to this bug.