[config] Add support for MX mail.ipax.at domains

RESOLVED FIXED

Status

Webtools
ISPDB Database Entries
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Thomas Hava, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [config])

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.10) Gecko/20100915 Ubuntu/10.04 (lucid) Firefox/3.6.10
Build Identifier: 

Please append the attached xml file to
https://live.mozillamessaging.com/autoconfig/

Best Regards,
Thomas Hava

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 478517 [details]
autoconfiguration file for domain MX mail.ipax.at

Comment 2

8 years ago
i'd like to second that ;)
Attachment #478517 - Attachment mime type: application/octet-stream → text/xml
Attachment #478517 - Flags: review?(ben.bucksch)

Comment 3

8 years ago
First, please read <https://developer.mozilla.org/en/Thunderbird/Autoconfiguration>.

That config not going to work.
1. This is an old config file, please attach v1.1
2. For MX, we look up only the SLD, so ipax.at
3. Did you consider setting up an autoconfig server yourself? (docs above)
   Please seriously consider whether that's possible.

Updated

8 years ago
Attachment #478517 - Flags: review?(ben.bucksch) → review-
(Reporter)

Comment 4

8 years ago
I have generated the configuration file as described within this article:
http://support.mozillamessaging.com/bg/kb/ISP+Database

If you download the XML file from https://ispdb.mozillamessaging.com/details/702 you'll receive the file I have attached to this autoconfiguration request.

Regarding the autoconfig server, we currently do not want to configure a autoconfig subdomain for each customer domain. To reduce the configuration effort for isps and of course the traffic to your ispdb servers i would suggest the following lookup order (step 3 is new):

1. tb-install-dir/isp/example.com.xml on the harddisk
2. check for autoconfig.example.com
3. look up "MX example.com" in DNS, and for mx1.mail.hoster.com, check for "autoconfig.hoster.com"
4. look up of "example.com" in the ISPDB
5. look up "MX example.com" in DNS, and for mx1.mail.hoster.com, look up "hoster.com" in the ISPDB
6. try to guess (imap.example.com, smtp.example.com etc.)
(Reporter)

Comment 5

8 years ago
Created attachment 478743 [details]
autoconfiguration file for domain ipax.at
Attachment #478517 - Attachment is obsolete: true

Comment 6

8 years ago
> I have generated the configuration file as described within this article:
> http://support.mozillamessaging.com/bg/kb/ISP+Database

Yes, that's wrong, I'll correct it.

> Regarding the autoconfig server, we currently do not want to configure a
> autoconfig subdomain for each customer domain.

Why not? You also add imap. and mx1., no?

> 3. look up "MX example.com" in DNS, and for mx1.mail.hoster.com, check for
> "autoconfig.hoster.com"

That would be yet another DNS lookup, and they can take long. We might do that after we parallelized the requests.
Summary: [Autoconfiguration] Add support for MX mail.ipax.at domains → [config] Add support for MX mail.ipax.at domains
Whiteboard: [config]
(Reporter)

Comment 7

8 years ago
>> Regarding the autoconfig server, we currently do not want to configure a
>> autoconfig subdomain for each customer domain.

> Why not? You also add imap. and mx1., no?

No we currently dont add subdomains like pop., imap. etc.

>> 3. look up "MX example.com" in DNS, and for mx1.mail.hoster.com, check for
>> "autoconfig.hoster.com"

> That would be yet another DNS lookup, and they can take long. We might do that
> after we parallelized the requests.

Yes indeed, but i would rather prefer one more DNS lookup, then using the "try to guess" heuristic which causes much more overhead.

Is the xml configuration valid by now?

Updated

8 years ago
Attachment #478743 - Attachment mime type: application/octet-stream → text/xml
Attachment #478743 - Flags: review?

Comment 8

8 years ago
Comment on attachment 478743 [details]
autoconfiguration file for domain ipax.at

> Is the xml configuration valid by now?

Looks good to me. 2 minor things:
- Remove addThisServer and useGlobalPreferredServer
- SSL cert is a cheap-o rapidssl .
  (You could try startssl.com for free and better certs)
Attachment #478743 - Flags: review? → review+

Comment 9

8 years ago
One question: how many customers does your company have? How many mail accounts?

The reason why I ask is that every config costs time (like this review and keeping it uptodate). The ISPDB is intended for big ISPs with a few hundred thousand users *at least*, otherwise it's just too much work to maintain manually.

That's why we have the autoconfig server solution that you host yourself.

> No we currently dont add subdomains like pop., imap. etc.

But you have to add MX to all domains anyway.

Updated

8 years ago
Attachment #478743 - Flags: review?(sancus)

Comment 10

8 years ago
(BTW: pop. and autoconfig. are hosts, not domains. No separate NS record necessary.)
(Reporter)

Comment 11

8 years ago
> - SSL cert is a cheap-o rapidssl .
> (You could try startssl.com for free and better certs)

Thank you for your recommendation - we're going to take this SSL provider into consideration for the next cert renewal. Why do you think that rapidssl is "cheap-o"?

> One question: how many customers does your company have? How many mail
> accounts?

I am not going to post this information in public, but we do not serve >100.000 clients at the moment. So we're not classified as a 'big' provider in your terms. I understand your concerns that smaller isps would be some kind of overkill for your support team, but i am wondering why you keep the manual review process as the ispdb is already available.

To bring this conversation to an end. We're planning to introduce the auto provider hosted discover feature for thunderbird, but a this moment the ispdb
lookup is the best solution.
(Reporter)

Comment 12

8 years ago
Created attachment 479352 [details]
autoconfiguration file for domain ipax.at
Attachment #478743 - Attachment is obsolete: true
Attachment #478743 - Flags: review?(sancus)
(Reporter)

Comment 13

8 years ago
Created attachment 479353 [details]
autoconfiguration file for domain ipax.at

Add correct file extension
Attachment #479352 - Attachment is obsolete: true

Comment 14

8 years ago
> i am wondering why you keep the manual
> review process as the ispdb is already available.

Bug 526559

Updated

8 years ago
Attachment #479353 - Flags: review+

Updated

8 years ago
Attachment #479353 - Flags: review?(sancus)
(Reporter)

Comment 15

8 years ago
Thank you for your feedback and the positive review. I really appreciate your fast responses!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 479353 [details]
autoconfiguration file for domain ipax.at

apologies for the delay here, this looks fine
Attachment #479353 - Flags: review?(sancus) → review+
(Reporter)

Comment 17

8 years ago
Great, thank you for your reviews! Looking forward to the publication.

Comment 18

8 years ago
Commited as SVN Revision 78523
FIXED
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

7 years ago
Blocks: 696180
Component: ispdb → ISPDB Database Entries
Product: Mozilla Messaging → Webtools
You need to log in before you can comment on or make changes to this bug.