Error while syncing, after adding a master password to a profile previously successfully synced

RESOLVED DUPLICATE of bug 443386

Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 443386
7 years ago
7 years ago

People

(Reporter: Dario Bertini, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; it; rv:1.9.2.10) Gecko/20100922 Ubuntu/10.10 (maverick) Firefox/3.6.10
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; it; rv:1.9.2.10) Gecko/20100922 Ubuntu/10.10 (maverick) Firefox/3.6.10

After adding a master password to an account without master password (but already synced ), the sync stops working with an unknown error.

Reproducible: Always

Steps to Reproduce:
1.Have a firefox profile without master password correctly synced
2.Create a new master password and enable FIPS
3.Try to sync again (may happen bug #570831, but after that the login is successful)
Actual Results:  
The login is successful, but fx sync complains about an unknown error

Expected Results:  
-overwrite the passwords on the server with the new encrypted ones
OR
-warn that the passwords synced weren't previously encrypted, and so there could be some problems
OR
-sync as much as possible, but skip/error/crash on passwords  

any of these would be a better outcome

I'm not sure if enabling FIPS is required for the bug, but the two times i reproduced it i used the same settings...

The sync server continues to work: after the bug on the first computer, i went home, and was able to sync successfully on the second pc (same synced data) even after activating the master password on the first pc... then obviously stops working after adding the master password also on this pc
(Reporter)

Comment 1

7 years ago
Created attachment 478542 [details]
about:buildconfig

forgot to mention: the firefox sync extension is @version 1.4.4
(Reporter)

Comment 2

7 years ago
again i forgot: the bug happens also if you disable the syncing of the passwords
FIPS mode isn't currently supported by Sync. Resolving this as a dupe. Please reopen if you continue to have problems even with FIPS mode disabled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443386
You need to log in before you can comment on or make changes to this bug.