Closed Bug 599660 Opened 9 years ago Closed 5 years ago

XUL panels should take into account -moz-transform property

Categories

(Core :: XUL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
blocking2.0 --- -

People

(Reporter: jk1700, Assigned: Gijs)

References

Details

(Keywords: css3, html5)

Attachments

(2 files)

379 bytes, text/html
Details
306 bytes, text/html
Details
User-Agent:       Opera/9.80 (Windows NT 6.1; U; pl) Presto/2.6.30 Version/10.62
Build Identifier: 

See the attached testcase and comment for bug 467442 - this is similar case I think

Reproducible: Always

Steps to Reproduce:
1. Open the testcase
2. Press the "Submit" button on any form
Actual Results:  
Error messages are not aligned with input fields

Expected Results:  
Error messages should be aligned with input fields

Moreover, the box shadow in the second form is clipped
Attached file Test case
Keywords: html5
Version: unspecified → Trunk
Blocks: 561636
Blocks: 435293
Component: General → Layout
Keywords: css3
Product: Firefox → Core
QA Contact: general → layout
Summary: Error messages should take into account -moz-transform property → Input validation error messages should take into account -moz-transform property
Attached file testcase 2
might confuse users
This is actually not really related to form validation error messages. Technically, we rely on the XUL panel element to show the message correctly.
Status: UNCONFIRMED → NEW
Component: Layout → XP Toolkit/Widgets: XUL
Ever confirmed: true
QA Contact: layout → xptoolkit.xul
Summary: Input validation error messages should take into account -moz-transform property → XUL panels should take into account -moz-transform property
I've created a separate bug 600264 for the box-shadow clipping
Not blocking unless this affects the Firefox UI in a way that isn't explained in this bug.
blocking2.0: ? → -
(In reply to comment #5)
> Not blocking unless this affects the Firefox UI in a way that isn't explained
> in this bug.

I'm not sure if it wasn't clear that the form validation error message wasn't shown correctly in the test cases because of this bug or this is not enough to be a blocker?
It wasn't clear. I now understand the UI impact, and don't believe that this is a blocker.
Bug 467442 fixed this.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
QA Whiteboard: [good first verify]
Moving to Core:XUL per https://bugzilla.mozilla.org/show_bug.cgi?id=1455336
Component: XP Toolkit/Widgets: XUL → XUL
You need to log in before you can comment on or make changes to this bug.