Sometimes, Tabs do not close completely and leave behind remnants

RESOLVED DUPLICATE of bug 608589

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 608589
7 years ago
5 years ago

People

(Reporter: ronin.achilles, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20101001 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20101001 Firefox/3.5

This does not happen always.. but from time to time, when you close a tab, it does not really close properly
- It leaves a shadow kind of remnant between two tabs (where it existed)
- It also shows up in the 'AllTabs' panel

Unable to find the exact steps to reproduce it, but has been happening for almost a couple of months now. 

Reproducible: Always
(Reporter)

Updated

7 years ago
Summary: Sometimes, closing a Tab leaves behind remnants → Sometimes, Tabs do not close completely and leave behind remnants
(Reporter)

Comment 1

7 years ago
This is a complete guess, but it might be related to Tab Closing animation.. what you really see is something like this...
Lets say there are 3 tabs - A, B, C

- Close tab B
- Tab B animates to close but doesn't close completely, the last shadow part remains..
- Active tab is changed to Tab C
- Tab B continues to exist in the 'AllTabs' panel and the shadow remnant continues to show on the Tab Bar, unless the browser is restarted. If Tab B is closed from the All Tabs panel, the remnant goes away, but the tab continues to exist in the All Tabs panel.

So really not sure whats going on here...
Blocks: 596954
(Reporter)

Comment 2

7 years ago
Created attachment 478638 [details]
Remnant of the Closed Tab

Attached screenshot showing the remnant of the Closed Tab.
Dao, dupe of bug 585785? Just for closing? Or should it be handled separately?

Comment 4

7 years ago
Created attachment 478746 [details]
Another screenshot of this happening (Windows XP)

I've been experiencing the same issue since beta 4 (maybe even before that).  On beta 4, I could actually click on the 'phantom tab' to view it, or hover the mouse over it to see its title in a tooltip.  I could also move it around on the tab bar.  (Couldn't close it though.)  On beta 6, I can still move the shadow tab around on the tab bar and see its title in a tooltip on hover, but I can no longer view its contents.  The only way I've been able to close these phantom tabs (without losing my other tabs) is to close FF and save open tabs.  Then when I restart FF, the phantom tab is reincarnated back into a full-fledged tab and I can close it.

Comment 5

7 years ago
More info:  When a normal tab is closed and happens to become a phantom tab, the tab continues to stay alive.  This happened today when I closed a tab that was playing a video on YouTube and I could still hear the video playing after the tab was 'closed' and became a phantom tab.

Also, in some cases, the phantom tabs do not return after Firefox has been restarted.  It seems pretty random as to whether they are resurrected as normal tabs or completely gone when Firefox restarts.
I'm having this happen as well.

Trying to close those phantom tabs from the taskbar preview logs the following errors to the console: 
Error: win is undefined
Source File: resource://gre/modules/WindowsPreviewPerTab.jsm
Line: 192
Error: browser.webProgress is undefined
Source File: chrome://browser/content/tabbrowser.xml
Line: 1439
Maybe TabCandy related?

Comment 8

7 years ago
Seems like I experience this issue more often with beta 7.  Sometimes if I play around with the phantom tab enough - sending it to other tab groups or making it an app tab, I can get it to show itself like a regular tab again.  However, I still can't actually close the tab without restarting FF.

Updated

7 years ago
No longer blocks: 596954
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608589
You need to log in before you can comment on or make changes to this bug.