Last Comment Bug 599961 - MacOSX 8.8.1 builds on mozilla-1.9.2 have binary spew in tinderbox logs
: MacOSX 8.8.1 builds on mozilla-1.9.2 have binary spew in tinderbox logs
Status: RESOLVED FIXED
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: x86 Mac OS X
: P2 major (vote)
: ---
Assigned To: Chris AtLee [:catlee]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-27 12:46 PDT by Lukas Blakk [:lsblakk] use ?needinfo
Modified: 2013-08-12 21:54 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Backout revision d94b2b27d220 on default branch. (9.99 KB, patch)
2010-09-29 10:52 PDT, Chris AtLee [:catlee]
rail: review+
Details | Diff | Review

Description Lukas Blakk [:lsblakk] use ?needinfo 2010-09-27 12:46:42 PDT
Example:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1285588445.1285588512.20210.gz&fulltext=1

Seems like a gzip bug on tbox since the buildbot-side log is legible.
Comment 1 Mark Banner (:standard8) 2010-09-27 13:06:38 PDT
Going back through tinderbox history this has been occurring since probably before 2010/08/18.

This has probably also potentially contributed to a presumably unnoticed regression in the Talos tests on 1.9.2.

gozer has told me that he's fixed something like this before with buildbot with this patch:

http://hg.mozilla.org/build/buildbot/rev/bbb93feea7a2
Comment 2 Nick Thomas [:nthomas] 2010-09-28 02:38:10 PDT
These Tiger talos runs live on an old Buildbot 0.7.10 install on talos-master.m.o. I doubt we deployed the gzip fix there, but might have accidentally turned on gzip at some earlier point. We're using buildbotcustom of rev 5683977a2707, and buildbot-configs of 5be6f01c2027, which would imply it was last updated on Aug 13.

The fail in talos will be a regression from the talos change in bug 598507. The buildbot logs have 
  *error: arch takes no arguments
Probably should farm that out to another bug, and possibly just change the check to |platform.mac_ver()[0][:4] == '10.5'|.
Comment 3 Chris AtLee [:catlee] 2010-09-28 08:17:34 PDT
Memory fails to tell me why we backported the gzip patch to the old buildbotcustom.  Happened in revision d94b2b27d220.
Comment 4 Nick Thomas [:nthomas] 2010-09-28 13:41:37 PDT
Bug 600328 filed for the orange on 1.9.1 and 1.9.2.
Comment 5 Chris AtLee [:catlee] 2010-09-29 10:52:00 PDT
Created attachment 479449 [details] [diff] [review]
Backout revision d94b2b27d220 on default branch.

I suggest we land this on a new 'buildbot-0.7' branch.
Comment 6 Rail Aliiev [:rail] 2010-09-29 11:37:54 PDT
Comment on attachment 479449 [details] [diff] [review]
Backout revision d94b2b27d220 on default branch.

looks good
Comment 7 Ben Hearsum (:bhearsum) 2010-10-01 10:26:45 PDT
Landing on Monday.
Comment 8 Ben Hearsum (:bhearsum) 2010-10-04 07:44:11 PDT
Should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.