Flush localStorage databases asynchronously

RESOLVED DUPLICATE of bug 807021

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 807021
8 years ago
4 years ago

People

(Reporter: sdwilsh, Unassigned)

Tracking

({main-thread-io})

Trunk
main-thread-io
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
We should flush the async database for localStorage asynchronously using the async storage API instead of doing it synchronously on the main thread.  Bug 536544 adds in-memory tables to buffer them at least.
Is that still valid?
Flags: needinfo?(vdjeric)
(In reply to David Rajchenbach Teller [:Yoric] <needinfo? me> from comment #1)
> Is that still valid?

No, I landed this change in bug 807021.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(vdjeric)
Resolution: --- → DUPLICATE
Duplicate of bug: 807021
You need to log in before you can comment on or make changes to this bug.