Download Manager & exthandler writes to files on the main thread

RESOLVED DUPLICATE of bug 789932

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 789932
7 years ago
5 years ago

People

(Reporter: sdwilsh, Unassigned)

Tracking

({main-thread-io})

Trunk
main-thread-io
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Both of these download files, and do so by writing to disk on the main thread.  We should really stop doing that.
I could have sworn we had a bug on this for exthandler, but I don't see it right now....
bug 789932 fixed exthandler. Download manager is covered by work in bug 825588
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 789932
You need to log in before you can comment on or make changes to this bug.