Closed Bug 600096 Opened 9 years ago Closed 9 years ago

img alt text does not display with a img src containing a path, javascript

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 25537

People

(Reporter: mailist, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729; .NET4.0E)

newImg.alt="scubadivesea - Cozumel Island, Mexico - age 32"
newImg.src="/files/main/thumbs/15545/tDX.jpg"
   mouse-over image does not display the popup containing the alt text
newImg.src="tDX.jpg", 
   mouse-over image does display the popup containing the alt text

Works properly with IE 8.0

Reproducible: Always

Steps to Reproduce:
1. display an image by setting DOM attributes of an image
2.
3.
Actual Results:  
Nothing happens when you mouse-over the image

Expected Results:  
The alt text appears in a popup box when you mouse-over the image

Tested Firefox under Windoze and Linux, same results.  Without proper functionality, my window displaying scrolling thumbnails is not very useful.
alt is for the alternative to the image when you can't see it because images have been disabled. You want the title attribute. It is IE that has the bug, it should not use the alt attribute as the image title.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: NoTooltip
> Works properly with IE 8.0
Actually it "works" only in quirks/IE7 mode. IE8 fixed the bug in IE8 mode.
You need to log in before you can comment on or make changes to this bug.