Closed Bug 600104 Opened 9 years ago Closed 9 years ago

Bump minimum required version for system NSS to 3.12.8

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(blocking2.0 final+, blocking1.9.2 .11+, status1.9.2 .11-fixed, blocking1.9.1 .14+, status1.9.1 .14-fixed)

RESOLVED FIXED
mozilla2.0b7
Tracking Status
blocking2.0 --- final+
blocking1.9.2 --- .11+
status1.9.2 --- .11-fixed
blocking1.9.1 --- .14+
status1.9.1 --- .14-fixed

People

(Reporter: mozilla-bugs, Assigned: reed)

References

Details

Attachments

(1 file)

/build/buildd/xulrunner-2.0-2.0~b7~hg20100926r54658+nobinonly/build-tree/mozilla/security/manager/ssl/src/nsNSSErrors.cpp:163: error: 'SSL_ERROR_WEAK_SERVER_EPHEMERAL_DH_KEY' was not declared in this scope
make[6]: *** [nsNSSErrors.o] Error 1

This was added here:
http://hg.mozilla.org/mozilla-central/rev/d04cc71e768b
to fix bug 587407

Is NSS 3.12.8 now required for mozilla-central?
Summary: mozilla-central won't build with the system NSS 3.12.7 → mozilla-central won't build with system NSS 3.12.7
Micah: thank you for the bug report.  I expected to hear from you.

SSL_ERROR_WEAK_SERVER_EPHEMERAL_DH_KEY is new in NSS 3.12.8.  It
is not defined as a macro, so we can't use conditional compilation.

You can replace SSL_ERROR_WEAK_SERVER_EPHEMERAL_DH_KEY with its
value -12173, if you want to build with system NSS 3.12.7.  I
recommend requiring NSS 3.12.8.
(In reply to comment #1)
> Micah: thank you for the bug report.  I expected to hear from you.
> 
> SSL_ERROR_WEAK_SERVER_EPHEMERAL_DH_KEY is new in NSS 3.12.8.  It
> is not defined as a macro, so we can't use conditional compilation.
> 
> You can replace SSL_ERROR_WEAK_SERVER_EPHEMERAL_DH_KEY with its
> value -12173, if you want to build with system NSS 3.12.7.  I
> recommend requiring NSS 3.12.8.

Should I move this to build config and propose bumping minimum NSS to 3.12.8?
That sounds good.

I'm still new to the minimum NSS requirement problem.
Do you usually want to avoid bumping the minimum NSS
version requirement?
Blocks: 595300
No longer blocks: 587407
blocking1.9.1: --- → ?
blocking1.9.2: --- → ?
blocking2.0: --- → ?
status1.9.1: --- → ?
status1.9.2: --- → ?
Component: Security: PSM → Build Config
OS: Linux → All
QA Contact: psm → build-config
Summary: mozilla-central won't build with system NSS 3.12.7 → Bump minimum required NSS version to 3.12.8
Summary: Bump minimum required NSS version to 3.12.8 → Bump minimum required version for system NSS to 3.12.8
Attached patch patch - v1Splinter Review
Assignee: nobody → reed
Status: NEW → ASSIGNED
Attachment #479206 - Flags: review?(wtc)
Attachment #479206 - Flags: approval2.0?
Attachment #479206 - Flags: approval1.9.2.11?
Attachment #479206 - Flags: approval1.9.1.14?
blocking1.9.1: ? → .14+
blocking1.9.2: ? → .11+
Attachment #479206 - Flags: approval1.9.2.11?
Attachment #479206 - Flags: approval1.9.2.11+
Attachment #479206 - Flags: approval1.9.1.14?
Attachment #479206 - Flags: approval1.9.1.14+
Comment on attachment 479206 [details] [diff] [review]
patch - v1

r=wtc.
Attachment #479206 - Flags: review+
Comment on attachment 479206 [details] [diff] [review]
patch - v1

Branch blocker now, so don't need approval2.0
Attachment #479206 - Flags: approval2.0?
blocking2.0: ? → final+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.