Android not starting on Tracemonkey due to ENABLE_SHARED_JS=1

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: mwu, Assigned: mwu)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
Created attachment 479205 [details] [diff] [review]
Only ENABLE_SHARED_JS on Windows
Attachment #479205 - Flags: review?(khuey)
Comment on attachment 479205 [details] [diff] [review]
Only ENABLE_SHARED_JS on Windows

:-P
Attachment #479205 - Flags: review?(khuey) → review-
(Assignee)

Comment 2

7 years ago
Created attachment 479207 [details] [diff] [review]
Only ENABLE_SHARED_JS on Windows, v2
Attachment #479205 - Attachment is obsolete: true
Attachment #479207 - Flags: review?(khuey)

Comment 5

7 years ago
checked this into to TM for a test.

http://hg.mozilla.org/tracemonkey/rev/49890751e255

Updated

7 years ago
Whiteboard: fixed-in-tracemonkey

Updated

7 years ago
blocking2.0: --- → beta7+
RE: reporting the PGO crash to Microsoft. When Luke's code was triggering that crash in the optimizer, I generated a linkrepro and attached it to a bug I filed at Microsoft Connect:
http://support.microsoft.com/kb/974229

It makes the linker copy all the input files and command line options to a directory that you can zip up and attach to a bug report. We should definitely try to do that if the linker crash is 100% reproducible. We should also probably try reproducing with Visual C++ 2010, because if it's already fixed there they're likely to just resolve our bug as DONTCARE.

Comment 7

7 years ago
(In reply to comment #5)
> checked this into to TM for a test.
> 
> http://hg.mozilla.org/tracemonkey/rev/49890751e255

Doing this appears to have fixed both the Android issue and the OS 10.5.8 issue.

Comment 8

7 years ago
http://hg.mozilla.org/mozilla-central/rev/49890751e255
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Depends on: 601109

Updated

7 years ago
No longer depends on: 601109
(In reply to comment #6)
> RE: reporting the PGO crash to Microsoft. When Luke's code was triggering that
> crash in the optimizer, I generated a linkrepro and attached it to a bug I
> filed at Microsoft Connect:
> http://support.microsoft.com/kb/974229
> 
> It makes the linker copy all the input files and command line options to a
> directory that you can zip up and attach to a bug report. We should definitely
> try to do that if the linker crash is 100% reproducible. We should also
> probably try reproducing with Visual C++ 2010, because if it's already fixed
> there they're likely to just resolve our bug as DONTCARE.

Ted: can you file another bug and do this?  Repro should be as simple as turning on static JS for windows and pushing to try, plus whatever you have to do to the build system generate the linkrepro.  Would really like to get libjs back into libxul, it's making Taras sad. :-( :-( :-(
You need to log in before you can comment on or make changes to this bug.