Closed Bug 600388 Opened 10 years ago Closed 10 years ago

[d3d] Black browser windows after OS screen lock with Intel graphics cards on Windows XP

Categories

(Core :: Graphics, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta8+

People

(Reporter: bemguard-bugzilla, Assigned: bas.schouten)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100928 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100928 Firefox/4.0b7pre

Using Thinkpad T61 with Windows XP on SP3.  The T61 uses an Intel 965 chipset, which has a GMA X3100 graphics chip.   

I'm using this machine with the current 6.14.10.5218 drivers provided by Lenovo   (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-67838)

Reproducible: Always

Steps to Reproduce:
1.Install Minefield and start.   
2.Examine browser window
3.Press CTRL-ALT-DEL together to bring up Windows XP dialog with "Lock Screen", "Shutdown", "Logoff", etc. , but don't bother to select any of them
4.Press ESC or click Cancel to return to regular XP user interface.
5.Examine browser window
Actual Results:  
Browser window interior is completely black, but still retains window border, window icon, window title, and min, max, and close controls.

Expected Results:  
Browser window should still be visible

There are two workarounds -
1)  Open a new window, then minimize and maximize the view
2)  Open a new tab, then minimize and maximize the view

This causes all the windows to revert back to a viewable interior.

There have been reports that older driver versions  (6.14.10.4785) do not suffer this problem, but others do  (v6.14.10.4980).

Intel's public drivers are not as new as the Lenovo ones, being at 6.14.10.5016   (http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Desktop+graphics+controllers&ProductProduct=Intel%C2%AE+82G965+Graphics+and+Memory+Controller+Hub+%28GMCH%29)
See Bug 593939 for previous discussion.
blocking2.0: --- → ?
Version: unspecified → Trunk
Depends on: 593939
The problem disappeared from my machine after updating to last nightly...
Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100928 Firefox/4.0b7pre
Someone else pls confirm.
Using Mobile Intel(R) 4 Series Express Chipset Driver v6.14.10.4980 dated
25/08/2008.
Assignee: nobody → bas.schouten
blocking2.0: ? → beta8+
The sample C# DirectX 9 windowed app provided at this website:

http://www.drunkenhyena.com/cgi-bin/view_net_article.pl?chapter=2;article=10
(bottom of the page)

doesn't seem to suffer from this same problem.
Seems to be resolved as a result of Bug 593678 patch.

WFM now with Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20101004 Firefox/4.0b7pre  (Built from http://hg.mozilla.org/mozilla-central/rev/192c38466579)
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Depends on: 604647
You need to log in before you can comment on or make changes to this bug.