Last Comment Bug 600626 - Use the last try: in a push's commit messages
: Use the last try: in a push's commit messages
Status: RESOLVED FIXED
[try-server]
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: x86 All
: P2 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 600631 (view as bug list)
Depends on:
Blocks: try_enhancements
  Show dependency treegraph
 
Reported: 2010-09-29 11:28 PDT by Lukas Blakk [:lsblakk] use ?needinfo
Modified: 2013-08-12 21:54 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
reversed(changes) to get latest commit message's try: first (844 bytes, patch)
2010-09-29 11:28 PDT, Lukas Blakk [:lsblakk] use ?needinfo
catlee: review+
bhearsum: checked‑in+
Details | Diff | Splinter Review

Description Lukas Blakk [:lsblakk] use ?needinfo 2010-09-29 11:28:02 PDT
Created attachment 479472 [details] [diff] [review]
reversed(changes) to get latest commit message's try: first

This came up in bug 600474 where each commit in a push had a try: line in it and the oldest one's -t none was the one used instead of the last commit's -t all

Reversing the changes when looking through the json push data gives the latest try: syntax to the scheduler.
Comment 1 Justin Lebar (not reading bugmail) 2010-09-29 11:36:04 PDT
*** Bug 600631 has been marked as a duplicate of this bug. ***
Comment 2 Lukas Blakk [:lsblakk] use ?needinfo 2010-09-29 12:55:51 PDT
Tested in staging with:


changeset:   53752:98e9581c7b83
user:        Lukas Blakk <lsblakk@mozilla.com>
date:        Wed Sep 29 11:44:42 2010 -0700
summary:     commit 1 try: -b o -p linux -m none -u none -t all

changeset:   53753:f8846de82ccb
user:        Lukas Blakk <lsblakk@mozilla.com>
date:        Wed Sep 29 11:44:59 2010 -0700
summary:     commit 2 try: -b o -p linux64 -m none -u none -t all

changeset:   53754:241ab9d7c1b7
tag:         tip
user:        Lukas Blakk <lsblakk@mozilla.com>
date:        Wed Sep 29 11:45:16 2010 -0700
summary:     commit 3 try: -b o -p macosx64 -m none -u none -t all

And got only the opt macosx64 build
Comment 3 Ben Hearsum (:bhearsum) 2010-10-01 10:53:33 PDT
Landing on Monday.
Comment 4 Ben Hearsum (:bhearsum) 2010-10-04 07:44:35 PDT
Landed.
Comment 5 Ben Hearsum (:bhearsum) 2010-10-04 07:48:55 PDT
Comment on attachment 479472 [details] [diff] [review]
reversed(changes) to get latest commit message's try: first

717110f59d82

Note You need to log in before you can comment on or make changes to this bug.