Find In Page should not close VKB as we search for text

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: aakashd, Assigned: vingtetun)

Tracking

Details

(Whiteboard: [VKB])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Build Id:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100930 Namoroka/4.0b7pre Fennec/4.0b1pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100930 Namoroka/4.0b7pre Fennec/4.0b1pre

Steps to Reproduce:
1. Go to www.mozilla.org
2. Click on the favicon to open the site panel
3. Click on "Find In Page"
4. Type in "mozilla" with each tap on the softkb key within 1/2-1 second of each other.

Actual Results:
At some point, the keyboard will close and the page will be panned to the closest match to the substring typed in the field.

Expected Results:
Fennec should wait a longer amount of time (let's say 500 ms more) before it begins to search for the string on the page.
(Reporter)

Updated

7 years ago
tracking-fennec: --- → ?
Why does the keyboard close? We can bump the timeout here and in the add-on search box too.
tracking-fennec: ? → 2.0+
Assignee: nobody → mark.finkle
We currently default to 500ms, so I can bump the timeout to 1sec and see how it feels
On second thought, I don't think we want to be less responsive when finding on a page. You could argue that searching AMO for add-ons does not need to happen every 500ms pause, but for local actions, like find-in-page, we should be faster.

Therefore, I am turning this bug into a VKB bug. We shouldn't close the keyboard when finding text.
Assignee: mark.finkle → 21
Summary: Fennec starts search of Find In Page string too quickly → [VKB] Find In Page should not close VKB as we search for text
Aakash, I'm not able to reproduce the: at some point the VKB close. Can you help me to reproduce it or check if the bug is still valid?
(Reporter)

Comment 5

7 years ago
Yeah, this is working for me now. Not sure what happened though.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 6

7 years ago
Created attachment 482422 [details]
no VKB in find in page screenshot

i hit this today consistently on Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101011 Firefox/4.0b8pre Fennec/4.0b2pre.

* See screenshot

Repro:
1) install the trunk nightly
2) open a website with text to search (eg. m.cbs.com)
3) click site icon, and select Find in Page
4) The VKB will appear.  start typing in something (eg. "cbs"), then hit enter
5) text gets highlighted in content.   Verify the Find in Page form filler gets moved to the bottom of the screen and clicking the text box does NOT open the virtual keyboard

Expected
- virtual keyboard appears each time i click the form filler for find in page.

ActualL:
- clicking focus in find in page filler does not always open virtual keyboard

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: [VKB] Find In Page should not close VKB as we search for text → Find In Page should not close VKB as we search for text
Whiteboard: [VKB]
This is frustrating because on my device (Milestone) on a busy page there's a delay between tapping the on-screen visible character on my virtual keyboard and the display of the character in the text field. If I am searching for "Microsoft" and I pause between key-presses, what gets searched is "Mi" or "Mic" with the virtual keyboard closing.
So the bug here is that the VKB closes. Maybe the textbox is getting blurred when a search happens.
If the bug came from a blur/focus change inside the page this will be fixed by bug 604192
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.