JM: "Assertion failure: fe_,"

RESOLVED DUPLICATE of bug 600419

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 600419
7 years ago
5 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86
Linux
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Reporter)

Description

7 years ago
Function("let e=b=x*=e<<e")()

asserts js debug shell on TM changeset 98c134cf59ef with -m at Assertion failure: fe_,
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?

Comment 1

7 years ago
Dup of bug 600419?
(In reply to comment #1)
> Dup of bug 600419?

Yes. Fixed by patch posted in that bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 600419
(Reporter)

Comment 3

7 years ago
Yup, autoBisect pretty much confirms this.

autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   54495:1bbc0fc10747
user:        David Anderson
date:        Tue Sep 21 18:34:42 2010 -0700
summary:     Optimize FrameState for large linear scripts (bug 591836, r=dmandelin).
Blocks: 591836

Updated

7 years ago
blocking2.0: ? → betaN+
A testcase for this bug was already added in the original bug (bug 600419).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.