[Regression] Typing uppercase requires holding down Shift button in content on Maemo (Qt)

RESOLVED WONTFIX

Status

Firefox for Android Graveyard
General
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: aakashd, Assigned: Brian Crowder)

Tracking

Details

(Whiteboard: maemo6 [hkb])

(Reporter)

Description

8 years ago
Build Id:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b7pre) Gecko/20100930 Namoroka/4.0b7pre Fennec/4.0b2pre

Steps to Reproduce:
1) go to www.google.com and tap on the search field
2) press the shift button once
3) enter in any letter key
4) Press and hold on the shift button and enter in any letter key

Actual Results:
The letter is not capitalized after step 3, but is captalized after step 4.

Expected Results:
The letter is capitalized after step 3 and 4.
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
(Reporter)

Comment 1

8 years ago
Btw, this was fixed in bug https://bugzilla.mozilla.org/show_bug.cgi?id=583327
Assignee: nobody → jimnchen+bmo
tracking-fennec: ? → 2.0b2+

Comment 2

8 years ago
marking fixed based on last comment.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Using the Hardware Keyboard, I am still seeing this issue on both Maemo and Android.

This doesn't occur on the Virtual Keyboard nor in the default web browser.  Should I reopen this bug or open a new bug?
This bug should not have been closed.  Comment 1 was noting that this was a regression of a previously-fixed bug, not that it has been fixed again.  Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: [Regression] Applying Upper case characters requires holding down the Shift button in web content → [Regression] Typing uppercase requires holding down Shift button in content on Maemo

Updated

8 years ago
tracking-fennec: 2.0b2+ → 2.0b3+

Updated

8 years ago
Assignee: jimnchen+bmo → nobody

Updated

8 years ago
Assignee: nobody → mkristoffersen

Comment 5

8 years ago
these sound like dups of each other -- probably a core problem and something that isn't platform specific.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599811
This is probably a different problem on the Maemo and the Android platforms
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Brian, I don't seem to be able to reproduce this on trunk or in the latest beta, can you verify?

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
Hmm... this seems to be a QT problem, not a GTK problem, which is the platform I tested on - do we have some way to set if the bug is Maemo/GTK or Maemo/QT ?

Anyway - it fails on trunk QT builds (where you need to hold down the shift key to get a capital letter)

Seems fine on GTK builds
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: [Regression] Typing uppercase requires holding down Shift button in content on Maemo → [Regression] Typing uppercase requires holding down Shift button in content on Maemo (QT)

Updated

8 years ago
Assignee: mkristoffersen → nobody
tracking-fennec: 2.0b3+ → 2.0+

Updated

8 years ago
Whiteboard: maemo6
(Assignee)

Updated

8 years ago
Assignee: nobody → crowderbt
(Assignee)

Comment 10

8 years ago
timeless, how do implementers usually handle this "latched" shift-key feature in Qt code?  Is there an approved technique?  Do we have to manually track the state?

Comment 11

8 years ago
from memory on our side we ran into headaches with this :)

Updated

8 years ago
Summary: [Regression] Typing uppercase requires holding down Shift button in content on Maemo (QT) → [Regression] Typing uppercase requires holding down Shift button in content on Maemo (Qt)

Updated

8 years ago
tracking-fennec: 2.0+ → 2.0-
Whiteboard: maemo6 → maemo6 [hkb]
(Assignee)

Comment 12

5 years ago
Ain't nobody got time fadat.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.