WebGL shader crash due to endless loop [@TOutputGLSL::visitLoop]

RESOLVED FIXED

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: posidron, Assigned: bjacob)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 480065 [details]
testcase
(Reporter)

Comment 1

8 years ago
Created attachment 480066 [details]
callstack
(Assignee)

Comment 2

8 years ago
Wait... this isn't a valid GLSL ES shader: indeed I don't think that the GLSL ES language allows infinite loop. So your shader should be rejected by the ANGLE shader validator. Since you say you're on Mac it should be enabled by default. Can you go to about:config and check the value of webgl.shader_validator ?
(Assignee)

Comment 3

8 years ago
Oh! i see! your stack trace points to ANGLE. Well congrats, you've found a nice ANGLE bug! Will reproduce later today on Windows and forward your bug to the ANGLE project; but do feel free to do that yourself, it will save me time!

http://code.google.com/p/angleproject/issues
blocking2.0: --- → ?
blocking2.0: ? → final+
Assignee: nobody → bjacob
(Assignee)

Comment 4

8 years ago
Reported upstream:
http://code.google.com/p/angleproject/issues/detail?id=50
Status: NEW → ASSIGNED
(Assignee)

Comment 5

8 years ago
(and confirmed here)
(Assignee)

Comment 6

7 years ago
This is fixed upstream in ANGLE, and since we recently synced our ANGLE copy, should be fixed for us too.

Please reopen if you can still reproduce this crash.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Blocks: 658170
You need to log in before you can comment on or make changes to this bug.