The default bug view has changed. See this FAQ.

reference font used for reftest "load-badchecksum.html" is rejected by OTS sanitizer

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(status1.9.2 .13-fixed, status1.9.1 .16-fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
The "good" reference font VeraBd-validchecksum.ttf, used by layout/reftests/font-face/load-badchecksum.html, is rejected by the OTS sanitizer. According to Apple's (not-very-thorough) ftxvalidator tool, there's a problem with the 'name' table.

Because this reference font is rejected, the reftest no longer works as intended once the sanitizer is deployed.
(Assignee)

Updated

7 years ago
Blocks: 527276
(Assignee)

Comment 1

7 years ago
This font is being rejected by the sanitizer because the final table in the font is not padded to a 4-byte boundary.
(Assignee)

Comment 2

7 years ago
Created attachment 480278 [details] [diff] [review]
patch, v1 - add proper padding to the VeraBd-validchecksum.ttf font file
Assignee: nobody → jfkthame
Attachment #480278 - Flags: review?(jdaggett)

Updated

7 years ago
Attachment #480278 - Flags: review?(jdaggett) → review+
(Assignee)

Comment 3

7 years ago
http://hg.mozilla.org/mozilla-central/rev/c1e91a637f57
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

7 years ago
Comment on attachment 480278 [details] [diff] [review]
patch, v1 - add proper padding to the VeraBd-validchecksum.ttf font file

Requesting approval for 1.9.2.13. This is a test-only patch, fixing an error in one of the test fonts we use; we need to fix this on branch, otherwise landing bug 527276 will lead to reftest failures because the incorrect font will no longer be loaded.
Attachment #480278 - Flags: approval1.9.2.13?
Comment on attachment 480278 [details] [diff] [review]
patch, v1 - add proper padding to the VeraBd-validchecksum.ttf font file

Approved for 1.9.2.13, a=dveditz for release-drivers
Attachment #480278 - Flags: approval1.9.2.13? → approval1.9.2.13+
(Assignee)

Comment 6

7 years ago
Pushed to 1.9.2:
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/df5318538e6e
(Assignee)

Updated

7 years ago
status1.9.2: --- → .13-fixed
(Assignee)

Comment 7

7 years ago
Comment on attachment 480278 [details] [diff] [review]
patch, v1 - add proper padding to the VeraBd-validchecksum.ttf font file

Requesting approval to land on 1.9.1, so that we can take the OTS font sanitizer there.
Attachment #480278 - Flags: approval1.9.1.16?
Comment on attachment 480278 [details] [diff] [review]
patch, v1 - add proper padding to the VeraBd-validchecksum.ttf font file

Approved for 1.9.1.16, a=dveditz for release-drivers
Attachment #480278 - Flags: approval1.9.1.16? → approval1.9.1.16+
(Assignee)

Comment 9

6 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/f404e712baaa
status1.9.1: --- → .16-fixed
You need to log in before you can comment on or make changes to this bug.