Closed Bug 601188 Opened 9 years ago Closed 9 years ago

Fennec cannot start on tracemonkey builds

Categories

(Core :: JavaScript Engine, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

RESOLVED INVALID
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: cmtalbert, Unassigned)

Details

Attachments

(1 file)

The tracemonkey tree has broken fennec.  It exhibits some varying behavior, but the net is always the same - Fennec can't start.

Due to the nature of the issue, it's a bit hard for me to determine exactly why we can't start, but here is the macro behavior that is being seen.

2010-10-1 - tm build -> dialog stating "error occurred when trying to load files required to run Fennec, fennec does not load.

2010-10-1 - mc build -> starts fine, browses to web pages etc.

= and the rest of this history are all tracemonkey builds =
2010-9-30 - no tm nightly built

2010-9-29 - build comes up, but does not load any content, it spins forever trying to load web pages, but chrome pages load fine (i.e. about:firstrun renders fine)

2010-9-27 - fennec crashes on startup
2010-9-26 - fennec crashes on startup 

2010-9-25 - fennec works normally.

verified these behaviors on both Android 2.1 and 2.2.
Severity: normal → major
Related to bug 601023 which was fixed on m-c? Maybe this was not picked up in tm yet.
(In reply to comment #1)
> Related to bug 601023 which was fixed on m-c? Maybe this was not picked up in
> tm yet.
Building a version of tm with this patch to see if it fixes the issue, will report back...
(In reply to comment #2)
> (In reply to comment #1)
> > Related to bug 601023 which was fixed on m-c? Maybe this was not picked up in
> > tm yet.
> Building a version of tm with this patch to see if it fixes the issue, will
> report back...
No, this patch doesn't seem to make any difference, I still get the same error :(

Do I need to rebuild my entire tracemonkey tree for this change to take effect or can I just apply the patch and make -C <objdir>/embedding (that's what I did).
tracking-fennec: --- → 2.0b2+
This bug was caused by Fennec's build arrangement, wherein the tip of mobile builds with tracemonkey or mozilla-central. This arrangement breaks when mobile depends on mozilla-central changes that are not yet on tracemonkey. In this case, I was able to pull in mozilla-central very quickly, but that may not always be practical. I have given this feedback a number of times.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.