Closed Bug 601258 Opened 9 years ago Closed 9 years ago

Mouse position in popupshowing event is bogus

Categories

(Core :: XUL, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 595570

People

(Reporter: gaubugzilla, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

343 bytes, application/vnd.mozilla.xul+xml
Details
Attached file Testcase
This issue caused some tooltips in Adblock Plus to break. When I looked into this it turned out that the mouse coordinates (event.clientX/Y, event.screenX/Y) received in popupshowing event of the tooltip are apparently entirely bogus and no longer depend on the actual mouse position. This makes custom tooltips on a tree widget pretty much impossible, without proper position it is not possible to tell which tree cell to show the tooltip for. Note that the default tooltips still work - apparently they take a different route that is only available for binary code.

The attached testcase demonstrates the problem. Download the testcase and open it from a chrome location (alternatively: use Remote XUL Manager to allow bugzilla.mozilla.org to serve remote XUL). Put the mouse somewhere, an alert message will display the screen/client coordinates received in popupshowing event. Now move the mouse somewhere else - note that the coordinates don't change.
This regressed between 2010-09-10 and 2010-09-11, regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8e0fce7d5b49&tochange=79d0beec27b5
This may be duplication of Bug 595570
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595570
You need to log in before you can comment on or make changes to this bug.