warning C4700: uninitialized local variable 'hr' used in ThebesLayerD3D10.cpp

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: RyanVM, Assigned: bas.schouten)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
mozilla-central\gfx\layers\d3d10\thebeslayerd3d10.cpp(137) : warning C4700: uninitialized local variable 'hr' used

74   HRESULT hr;
....
137       if (SUCCEEDED(hr)) {
138         retainedRegion.Or(retainedRegion, *r);
139       }
(Reporter)

Comment 1

8 years ago
Bas, what should this be initialized to? Should it follow the same pattern as ThebesLayerD3D9.cpp Line #154?
(Reporter)

Updated

8 years ago
Duplicate of this bug: 614682
(Assignee)

Comment 3

8 years ago
Created attachment 493459 [details] [diff] [review]
Properly retain copied region

This is actually a silly bug! It could cause excessive redrawing in some cases. This patch will fix it. Thanks for bringing this to my attention!
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
Attachment #493459 - Flags: review?(jmuizelaar)
Attachment #493459 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 4

8 years ago
We should get this in for FF4 :).
blocking2.0: --- → ?
blocking2.0: ? → final+
(Assignee)

Comment 5

8 years ago
http://hg.mozilla.org/mozilla-central/rev/ba2e3cdbaaf3
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.