search.t should also test the basic standard search parameters

RESOLVED FIXED in Bugzilla 4.2

Status

()

Bugzilla
Testing Suite
--
enhancement
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

Bugzilla 4.2
Dependency tree / graph
Bug Flags:
approval +

Details

Attachments

(2 attachments)

v1
4.22 KB, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
Fix
858 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Assignee)

Description

7 years ago
Right now, we only test things via the boolean charts, but we should also make sure that the standard search parameters (and particularly the special ones, like chfield) continue to work exactly as they always have (or better).
(Assignee)

Comment 1

7 years ago
Okay, I'm going to focus and limit this first bug to just testing the simple standard search parameters, the basic field=value ones.
Summary: search.t should also test the standard search parameters → search.t should also test the basic standard search parameters
(Assignee)

Comment 2

7 years ago
Created attachment 480393 [details] [diff] [review]
v1
Attachment #480393 - Flags: review+
(Assignee)

Updated

7 years ago
Flags: approval+
(Assignee)

Comment 3

7 years ago
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/                       
modified xt/lib/Bugzilla/Test/Search.pm
modified xt/lib/Bugzilla/Test/Search/FieldTest.pm                              
added xt/lib/Bugzilla/Test/Search/FieldTestNormal.pm
modified xt/lib/Bugzilla/Test/Search/OperatorTest.pm
Committed revision 7498.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

7 years ago
Oh, wait, there's a bug in this patch that is preventing it from actually doing the right thing.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

7 years ago
Depends on: 601370
(Assignee)

Updated

7 years ago
Depends on: 601371
(Assignee)

Comment 5

7 years ago
Created attachment 480403 [details] [diff] [review]
Fix

This fixes the search test to actually work. (The problem before was that it was re-using the existing search_params from $field_test.)
Attachment #480403 - Flags: review+
(Assignee)

Comment 6

7 years ago
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/                       
modified xt/lib/Bugzilla/Test/Search/FieldTestNormal.pm
Committed revision 7501.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.