No way to change printer for preview

RESOLVED DUPLICATE of bug 428539

Status

()

Core
Print Preview
--
enhancement
RESOLVED DUPLICATE of bug 428539
8 years ago
3 months ago

People

(Reporter: George Sexton, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(firefox6-)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

There's no way to change the active printer for print preview when using Firefox 3.6.10 with Windows.

Say for example, my default printer is a Letter Sized laser printer, and I would like to print to a different printer with Tabloid size paper. There's no way to change the printer for preview purposes. You have to either print blind, or print blind and then come back in to preview.

Reproducible: Always

Steps to Reproduce:
1.Setup two printers with different size paper
2.try to preview the non-default printer.
3.
Actual Results:  
It doesn't work.

Expected Results:  
There should be some way to change the active printer for preview purposes.

Updated

7 years ago
See Also: → bug 132017
Version: unspecified → 3.6 Branch

Comment 1

7 years ago
this has been a major annoyance for me as well. can someone please triage this?
tracking-firefox6: --- → ?

Comment 2

7 years ago
this doesn't meet the criteria for tracking.
tracking-firefox6: ? → -

Updated

7 years ago
Severity: normal → enhancement
Component: General → Print Preview
Product: Firefox → Core
QA Contact: general → printing
Version: 3.6 Branch → Trunk
Duplicate of this bug: 745531

Comment 4

4 years ago
I work in an organisation where we have numdreds of people printing A4 sheets on a laser printer then putting that sheet in an evelope then printing a label on a label printer then sticking that on the front of the envelope.

We cannot use Firefox becuse evertime we switch printers, Firefox chooses the paper size of the previous printer. The first page which is printed after switching to the other printer always would always have to go in the bin. 

As of version 37, Google have added a Paper Size option to their Chrome browser, so we are now using that.

Please, try to fix this in Firefox so that we can go back to using it.

Comment 5

3 years ago
I would really like to see this fixed.  One option would be to provide an "Apply" button to the Print Dialog along side the existing OK and Cancel buttons. Another would be to add a "Change Printer" button to the Print Preview bar along side "Print ..." and "Page Setup ...".

I have found a work-around, though it is a bit of a kludge:
 o Enter Print Preview.
 o Click on Print as if you were going to print.
 o Change the printer in the print dialog and any properties.
 o CHECK THE "Print to File" box, and then click on OK.
 o When you get the Dialog box asking for the Output File Name, click on Cancel.
 o You will get an error dialog saying "An error occurred while printing".  Click on OK.
 o Click on Portrait or Landscape button (whichever is not your current selection) to get the preview page rerendered.
 o Click on the Portrait or Landscape button for the view you want and now you should have an accurate print preview for your desired printer without having had to "Print Blind".

Updated

3 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428539
You need to log in before you can comment on or make changes to this bug.