searchbar-engine-button only child inside a very anonymous box without attributes

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: Exple1980, Assigned: Gavin)

Tracking

4.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

The button element with class and anonid "searchbar-engine-button" is placed inside a box element without any other children or any attributes. I am assuming this is a bug, because the only difference I see is that it unnecessarily breaks backward-compatibility with add-ons and unnecessarily complicates the DOM structure.
If this is not a bug and there is an advantage to this, then I apologize and please WONTFIX this.

Reproducible: Always



Expected Results:  
In older versions, searchbar-engine-button is simply placed inside searchbar-textbox.
(Reporter)

Updated

8 years ago
Summary: searchbar-engine-button inside a very anonymous box → searchbar-engine-button only child inside a very anonymous box without attributes
(Reporter)

Comment 1

8 years ago
The problem is in chrome://browser/content/search/search.xml, lines 37-52.
Version: unspecified → 4.0 Branch

Updated

5 years ago
Component: General → Search
Thanks for the report, but this is indeed intentional. The box is needed to properly position the button within the containing autocomplete binding (i.e. for it to fall into http://hg.mozilla.org/mozilla-central/annotate/cf80c0d4f46e/toolkit/content/widgets/autocomplete.xml#l27 rather than http://hg.mozilla.org/mozilla-central/annotate/cf80c0d4f46e/toolkit/content/widgets/autocomplete.xml#l32).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Though it would be good to add a comment about that in the file, did that in https://hg.mozilla.org/integration/mozilla-inbound/rev/0653ee9db9f2
You need to log in before you can comment on or make changes to this bug.