Switching to a list view before remote search completes results in install items added to new view

VERIFIED FIXED in mozilla2.0b8

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: Unfocused, Unassigned)

Tracking

Trunk
mozilla2.0b8
Points:
---
Bug Flags:
in-testsuite ?
in-litmus -

Firefox Tracking Flags

(blocking2.0 final+)

Details

1. Search for something that will return results
2. Before remote search completes, switch view (any list view that's not search)
3. Remote search results will be added to new view, as install items (that you can't do anything with, too)

This is another special case of the problem we had with displaying installs that were STATE_AVAILABLE. Once we show gListView, it starts listening for new installs (onNewInstall), which remote search results will then trigger. I question whether remote search results should be triggering onNewInstall at all - I can't think of any case where it would be useful.
blocking2.0: --- → ?
blocking2.0: ? → final+
Depends on: 591663
Whiteboard: [needs 591663]
Duplicate of this bug: 607350
Fixed by bug 591663, don't think the test there covers this case though.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite?
Flags: in-litmus-
Resolution: --- → FIXED
Whiteboard: [needs 591663]
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101212 Firefox/4.0b8pre
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla2.0b8
You need to log in before you can comment on or make changes to this bug.