Add an option to use HTTP connection instead of FTP to download updates

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Gabri, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
I've some problems to update Firefox at office under firewall that blocks ftp connections. I think we could use an option in about:config where users can decide to use HTTP (http://ftp.mozilla.org/) instead of FTP to update Firefox/Seamonkey/Thunderbird.
(Reporter)

Updated

8 years ago
Summary: Add an option to decide → Add an option to choose HTTP connection instead of FTP to download updates
(Reporter)

Updated

8 years ago
OS: Windows 7 → All
Hardware: x86 → All
(Reporter)

Updated

8 years ago
Summary: Add an option to choose HTTP connection instead of FTP to download updates → Add an option to use HTTP connection instead of FTP to download updates
As far as I know, we don't actually use FTP to do updates. The server that nightlies use for updating is called ftp.mozilla.org, but the connection is done via HTTP... Is there a reason you believe an actual FTP connection is being made and used?

Updated

8 years ago
Assignee: morgamic → nobody
Component: General → Application Update
Product: AUS → Toolkit
QA Contact: general → application.update
Version: 3.0 → Trunk
We do use http to download the updates. An example url
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2010/10/2010-10-03-04-mozilla-central/firefox-4.0b7pre.en-US.win32.complete.mar

Resolving -> invalid since this is already the case. If you'd like to file a new bug regarding the issues you are experiencing please do so with any / all relevant details to help us figure out what the problem is.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.