Copy and paste of a button in Composer editor corrupts the html code

RESOLVED DUPLICATE of bug 664095

Status

--
major
RESOLVED DUPLICATE of bug 664095
8 years ago
8 years ago

People

(Reporter: glw99, Unassigned)

Tracking

SeaMonkey 2.3 Branch

SeaMonkey Tracking Flags

(seamonkey2.3 affected, seamonkey2.4 fixed)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.12) Gecko/20100825 SeaMonkey/2.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.12) Gecko/20100825 SeaMonkey/2.0.7

Editing a file in Composer, Normal view, I swiped over and copied a Back to Top button – the HTML is:

<div style="text-align: right;"> <input value="Back to Top"
onclick='document.location.href="#top"' type="button"> </div>

and pasted it elsewhere in the page. The pasted version in HTML is:

<div style="text-align: right;"> <input value="Back to Top"
type="button"> </div>

i.e. the onclick='document.location.href="#top"' part is missing, so the appearance of the button is OK but it does nothing.
First noticed in version 2.0.8, but now identified also in version 2.0.7 (British and US English). Version 2.0.6 functions correctly.

Can’t find any similar bug reports.

Reproducible: Always

Steps to Reproduce:
1. Within any page, add a button using html code: 
<div style="text-align: right;"> <input value="Back to Top"
onclick='document.location.href="#top"' type="button"> </div>

2. In 'Normal' view, swipe over the button and copy it.

3. Put the cursor somewhere else on the page and paste the button.

4. Go to the HTML view and examine the pasted button code.
Actual Results:  
Code has lost the onclick='document.location.href="#top"' part, so the button doesn't work.

Expected Results:  
Up to and including version 2.0.6 this paste works fine, but 2.0.7.and 2.0.8 display this fault.

I don't have the know-how to delve any deeper into the bug, but it could potentially frustrate many users who do not have the ability to trace the defect through the HTML code.
Probably a dupe of Bug 597784. Can you test again with SeaMonkey 2.0.9? SeaMonkey 2.0.9 will probably be released around mid-October.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 597784
(Reporter)

Comment 2

8 years ago
Frank,
Just tested SM 2.0.9 - the fault is still the same: in SeaMonkey Composer, copy-and-paste of onclick='document.location.href="#top"' fails. Version 2.0.6 is OK.
Graham.
(Reporter)

Comment 3

8 years ago
Frank,
Just tested SM 2.0.10 - the fault is still the same: in SeaMonkey Composer,
copy-and-paste of onclick='document.location.href="#top"' fails. Version 2.0.6
is OK.
Graham.
(Reporter)

Comment 4

8 years ago
Frank,

Ehsan in Bug 597784 has said that this is nothing to do with that bug.

If it is not a dupe of 597784, please take another look. Whoever it belongs to, it is NOT fixed. I have posted a similar message in 597784 and hope someone picks it up.
Thanks.
Graham.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

8 years ago
Anyone picking this one up?
This is definitely NOT a duplicate of 597784, which has been resolved a long time ago.
This fault still exists in SeaMonkey 2.0.13, tested today 11 April 2011, so all versions from 2.0.7 onwards are defective.
Thanks,
Graham.
(Reporter)

Comment 6

8 years ago
Version 2.2 of SeaMonkey just took a step backwards: now, an attempt to copy and paste a button (e.g. <input name="Top" value="Back to Top" onclick='document.location.href="#top"' type="button">) in Normal view of SeaMonkey editor fails completely. Text around the button is correctly copied, but the code above is omitted. This must be a tip of the iceberg - lots of other code must surely be corrupted during a copy-and-paste operation. Anybody interested? Or do we abandon SeaMonkey as a wysiwyg page editor?
Graham.

Comment 7

8 years ago
Have done some testing:
Both 2.2 and 2.3beta do not allow the copying
2.4a2 does allow copying and does not mangle/corrupt the code.

As far as I can see this is something in the backend Gecko code that got broken in Gecko 1.9.x but was then fixed somewhere between Gecko 6.0 and Gecko 7.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → SeaMonkey 2.3 Branch

Comment 8

8 years ago
I can confirm that applying the patch from bug 664095 to mozilla-beta (which is Gecko 7 that SM2.3 will be released on), fixes the issue -> DUPLICATE
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 664095

Updated

8 years ago
status-seamonkey2.3: --- → affected
status-seamonkey2.4: --- → fixed
You need to log in before you can comment on or make changes to this bug.